Failed to apply patch - Mac - desperate

Mac Technical Support
I have googled this looking for some sort of workaround but nothing seems to help. I am starting from the Launcher. Always the same sequence, patch required, starts at 0%, restart, failed. I even downloaded the WoW setup again per some suggestion but that didn't help, although the Launcher looked updated. I don't want to reinstall the whole damn game because I doubt it's necessary, but I don't know what to do. Can anyone point me in the right direction?
Same thing with me!!!!

Started happening today... I open WoW and it does the update download, but then says patch required. I push restart to download the patch but then it says failed to apply patch
Bump.

I'm sure there is some relatively simple way to get past this issue, but it eludes me.
Delete WTF Folder. Delete Battle.net folder. Then try launching the game. Not sure if on the mac if battle.net folder is hidden or not. So may take a little hunting.
09/29/2012 07:41 PMPosted by Druenny
Delete WTF Folder. Delete Battle.net folder. Then try launching the game. Not sure if on the mac if battle.net folder is hidden or not. So may take a little hunting.

Thanks for response.
I've tried that, though. A couple times. Is there anything else I could try deleting?
Desperate bump. Looks like I might have to spend a couple days re-installing. Would really like to play this game I'm paying so much for.
Why isn't the launcher patching your game? Does it say that your game is up to date? The 'patch required' message isn't displayed until you launch the game and attempt to log in but the launcher shouldn't allow you to launch the game until it's up to date.
10/01/2012 04:27 PMPosted by Barthus
Why isn't the launcher patching your game? Does it say that your game is up to date? The 'patch required' message isn't displayed until you launch the game and attempt to log in but the launcher shouldn't allow you to launch the game until it's up to date.


I wish I knew.

The launcher does seem to think the game is up to date whenever I use it. Then it launches the game automatically.
You could try deleting the WTF folder then. Unless you already patched your client to 5.0+, if that's the case you should delete the Battle.net folder ('Mac HD' -> /Users/Shared/Battle.net)
So this is happening again.

I am on a macbook pro running OSX 10.7.5, 2.2GHz Core i7, and 4gb ddr3.

And all the above steps did nothing.

Starting from the launcher says game is fine and launches normally, in game download says it fails to patch.
What version is the launcher at?

You can find the World of Warcraft version in Finder by highlighting it and looking at the version.
________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
4.2.1

Edit: I have submitted a traceroute, system report, and most recent error report to someone I spoke with on the phone (Matthew).
Thanks for the info.

From your launch having that issue, and the version you posted, this means somehow the migration got corrupted.

The World of Warcraft Launcher should be at 1.0.0.1113, as it is using the new Blizzard Launcher/Agent updating system.

In order to resolve your specific issue, you will need to fully uninstall World of Warcraft, and reinstall with the updated WoW Setup. This should automatically start you off at patch 5.0.0, with the latest launcher, and fix the issue.

https://us.battle.net/support/en/article/uninstall-reinstall-instructions-for-patching-issues
________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
So the fact that I was playing yesterday, and all of a sudden today can not log in is due to a corrupted launcher from the MoP launch?

I will probably just be canceling my account and letting it run out, as this is ridiculous that during the 8th year of life a company can not successfully launch an expansion to a multi-billion dollar product.

At least until you guys un-break the background downloader, which worked perfectly.

Edit: Moved the launcher to trash can. Logged in fine.
Have you always used the launcher to open the game?

Bypassing the launcher can cause weird issues like this to happen, as the game itself cannot patch. Always use the launcher to open the game, as updates, small or big, must be patched thru there.

That launcher you have is from Cataclysm.
________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
I never use the launcher. I deleted it, double clicked the game icon, and logged in.

This is also the first log in issue I have ever had.
I've seen this sometimes work, but for the most part, bypassing the launcher isn't an intended function. Development/QA doesn't test with bypassing the launcher, so anything can happen when you don't follow the intended paths.

The World of Warcraft Launcher should always be used, as is is the intended way to update/patch the game. This holds true for StarCraft II and Diablo III.

________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
I never intended to bypass the launcher either, and have been having the same problem. When I downloaded the new expansion, suddenly the launcher (where the patching occurs) no longer shows up. Double clicking the WoW icon would send me straight into the game. Someone on the development team screwed up, I'm guessing. If the only thing I can do is uninstall and reinstall the game... not too thrilled with my options. Pretty bad for a product of this caliber.
SOrry to hear that. I can send this to the team that works on this aspect of the client and see if they can investigate this to prevent it in the future.

If you have any issues reinstalling please let us know.
________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
I had luck simply selecting Download Game Client from the battle.net WoW game tab. After the download I was able to login and play as normal.

Join the Conversation

Return to Forum