Can't gain any rep with Golden Lotus faction.

Bug Report
1 2 3 5 Next
PAY ATTENTION:

1. I obtained the first quest with The Golden Lotus faction in the Vale of Eternal Blossoms.

2. The first quest is a simple "walk up and turn it in" quest. Completed the quest under The Golden Pagoda area.

3. Noticed there were 2 or 3 yellow exclamation points on more heads than I wanted to do quests at that point in time.

4. Abandoned quests, as I am super OCD and hate having quests in my log that I am not going to do just yet.

5. Came back a day later, THERE ARE NO MORE EXCLAMATION POINTS ON ANY HEADS AND YOU NEED GOLDEN LOTUS REP TO OPEN UP OTHER DAILY QUESTS.

It seems like I am out of phase with the NPC's that I need to be talking to to get the second and third quests for The Golden Lotus faction.

NOTE: I already went back to the original Golden Lotus NPC.

ANOTHER NOTE: I have completed ALL of the quests for The Temple of the White Tiger, opened the gate... etc...

I sent Blizzard a ticket and they gave me a bull!@#$ response, as usual.
Exact same issue here. ANY kind of response would be a tremendous help, blues.

And for Pete's sake, DON'T just tell us to check and see if we did quest X. We did.
bumping this. I SO won't be cheated out of repping up three factions.
BUmping this again
bumping this as well. i'd like an answer.
Nothing on this yet?
bump as well. im annoyed.
I had heard it was something to do with a phasing issue and doing a pet battle in the Vale will fix it, you don't have to win it you can leave. I'm about to try it and see if it changes anything.

Edit: Didn't seem to change anything.
I havent even trained for pet battles so it has nothing to do with pet battles.
bump.
Having the same problem, I'm stuck at 0 Golden Lotus rep. I turned in that first Golden Lotus quest at the Golden Pagoda and no one there has any more quests for me.
bump
same issue please fix
bump
I was able to do the first quest hub at the Golden Stair today, but when they sent me to the second quest hub at the lake, the NPCs there are in a different phase and I can't talk to them. The ? for the questgiver shows up on my minimap, but I can't get any further Golden Lotus rep with this bug, and it's pretty frustrating.

Also, this isn't just me, this is everyone on the Uldaman server.
bumping, same issue as well
http://www.wowhead.com/news=205175/mists-of-pandaria-golden-lotus-preview-and-news-round-up
09/30/2012 01:22 PMPosted by Inslowmotion
I had heard it was something to do with a phasing issue and doing a pet battle in the Vale will fix it, you don't have to win it you can leave. I'm about to try it and see if it changes anything.


I just tried a pet battle in front of che with a guildie and it didnt work, BUT when i que'd for one in front of him and i returned the phasing issue was solved. May want to try that.
I found the solution. If you can't see the quests at the golden pagoda, head to the golden lotus camp near the ruins of guo-lai (33, 38) and you should see two quests there. Those two give way to three more and after you do all five, you unlock the dailies at golden pagoda. Hope this helps.

Join the Conversation

Return to Forum