An Internal Error Occurred

Mac Technical Support
I've been getting this error all morning from the launcher - everything was working fine last night. I started WoW this morning, the little updater icon flashed in the doc, then the launcher showed up, and now it has the following error:

"An internal error occurred, please restart. If problems persist contact customer support."

Well, the problem has persisted so I'm contacting customer support.. :-) There doesn't appear to be a repair tool anymore - I've whacked a few cache directories with no change either. I also haven't been able to find any log with more useful information.
mee too B(
How are you launching the game? (Dock icon, a desktop icon, directly from the WoW folder, etc).
Hi, Im having the exact same problem. Im launching the game from the wow folder itself.
We're having the same problem on one of our two systems here. One works just fine, both did last night in fact. But this morning something changed and the other only gets this error. We have two clients on that system, and both do this. We've tried launching from the regular client, the 64 bit and the launcher, from the folder and from the dock. Same effect on all. It's very strange, and I'm seeing a lot of people on the forums asking about it now. Both mac and pc people.
We're having the same problem on one of our systems of our two here. One works just fine, both did last night in fact. But this morning something changed and the other only gets this error. We have two clients on that system, and both do this. We've tried launching from the regular client, the 64 bit and the launcher. Same effect on all. It's very strange, and I'm seeing a lot of people on the forums asking about it now. Both mac and pc people.


I'm confused by your description.

Are you saying only one of your computers is having the issue while the other does not or are both computer systems affected ?
Only one computer is effected. The other is able to play the game with no problems at all.
Can you verify if your WoW directory looks like the one linked below? Also make sure you're using the World of Warcraft Launcher in this directory.

http://i50.tinypic.com/2isuxch.png
That's exactly it. And yes, we used the launcher from within the directory as well as from the dock.
Only one computer is effected. The other is able to play the game with no problems at all.


Try copying the wow programs from the working install of wow to the non working install of wow.

Only the 32 bit and 64 bit clients were changed in this build.
i am having the same issue this morning. Last night everything was fine.

if i launch from the wow dock icon or from the launcher in the wow folder i get the "internal error message come up".

if i go to the wow folder and try to launch from the wow 64 bit icon the same issue occurs.

if i move the wow-launcher out of the wow folder and click the wow 64 bit icon the game will open at the log on screen, if i put my password in i am prompted to restart and download the patch, when i click restart i get an error message stating "unable to apply patch - i may need to redownload game".

when i put the wow launcher back into the wow folder the game wont open to the log on screen, i just get the internal error issue again.

have tried all the fixes - nothing is working.
1. Make sure you didn't move the launcher out of the Wow folder.
2. Delete the Updates folder. (/Applications/World of Warcraft/Updates)
3. If the launcher is in the correct location and deleting the Updates folder doesn't help, try repairing your WoW install:
http://us.battle.net/wow/en/forum/topic/6794872983#5
Can y'all do me a favor and list the files that are in the directory, so we can be sure everything is correct? The easiest way is to copy/paste this terminal command and paste the output.

    1. Open Terminal (/Applications/Utilities)
    2. Copy/Paste:
    ls /Applications/World\ of\ Warcraft > ~/Desktop/wowfolder.txtThis will output a text file on your desktop named wowfolder.txt.
    3. Open the wowfolder.txt file and copy/paste the contents here.


Also, can you post your switcher.log file? This is located in /Users/Shared/Battle.net/Client/Logs. Make sure any computer/user names are removed from the log.
hi

pasting info from wow folder.txt as suggested

Cache
Data
Interface
Launcher.db
Logs
Movies
SetupOSX.mpq
Updates
WTF
WoW-3.2.0-enUS-downloader.app
WoW-3.2.0-enUS-patch.app
WoW-3.2.0.10192-to-3.2.0.10314-enUS-downloader.app
WoW-3.2.0.10192-to-3.2.0.10314-enUS-patch.app
WoW-3.2.0.10314-to-3.2.2.10482-enUS-downloader.app
WoW-3.2.0.10314-to-3.2.2.10482-enUS-patch.app
WoW-3.2.2.10482-to-3.2.2.10505-enUS-downloader.app
WoW-3.2.2.10482-to-3.2.2.10505-enUS-patch.app
WoW-3.2.2.10505-to-3.3.0.10958-enUS-downloader.app
WoW-3.3.0.10958-to-3.3.0.11159-enUS-downloader.app
WoW-3.3.0.10958-to-3.3.0.11159-enUS-patch.app
WoW-3.3.0.11159-to-3.3.2.11403-enUS-downloader.app
WoW-3.3.0.11159-to-3.3.2.11403-enUS-patch.app
WoW-3.3.2.11403-to-3.3.3.11685-enUS-downloader.app
WoW-3.3.3.11685-to-3.3.3.11723-enUS-downloader.app
WoW-3.3.3.11685-to-3.3.3.11723-enUS-patch.app
WoW-3.3.3.11723-to-3.3.5.12213-enUS-downloader.app
WoW-3.3.3.11723-to-3.3.5.12213-enUS-patch.app
WoW-3.3.5.12213-to-3.3.5.12340-enUS-downloader.app
WoW-3.3.5.12213-to-3.3.5.12340-enUS-patch.app
WoW-x.x.x.x-4.0.0.12911-Downloader.app
WoW.mfil
WoW.pfil
WoW.tfil
World of Warcraft 2.textClipping
World of Warcraft Launcher.app
World of Warcraft-64.app
wow-4.0.1.2120-enUS-tools-downloader.app
wow-4.0.1.2120-enUS-tools-patch.app
wow-4.0.1.2210-enUS-tools-downloader.app
wow-4.0.1.2210-enUS-tools-patch.app
wow-4.1.0.2317-enUS-tools-downloader.app
wow-4.1.0.2317-enUS-tools-patch.app
wow-4.1.0.2346-enUS-tools-downloader.app
wow-4.1.0.2346-enUS-tools-patch.app
wow-4.2.0.2492-enUS-tools-downloader.app
wow-4.2.0.2492-enUS-tools-patch.app
wow-4.2.0.2506-enUS-tools-downloader.app
wow-4.2.0.2506-enUS-tools-patch.app
wow-4.2.0.2552-enUS-tools-downloader.app
wow-4.2.0.2552-enUS-tools-patch.app
wow-4.2.1.2617-enUS-tools-downloader.app
wow-4.2.1.2617-enUS-tools-patch.app
wow-4.2.1.2685-enUS-tools-downloader.app
wow-4.2.1.2685-enUS-tools-patch.app
wow-4.2.1.2727-enUS-tools-downloader.app
wow-4.2.1.2727-enUS-tools-patch.app
wow-4.2.1.2730-enUS-tools-downloader.app
wow-4.2.1.2730-enUS-tools-patch.app
wow-4.2.1.2736-enUS-tools-downloader.app
wow-4.2.1.2736-enUS-tools-patch.app
switcher logs:

#-----------------------------------------------------------
# System started at 2012-10-11 01:05:29.3590
# system: MacBook Pro
#-----------------------------------------------------------
01:05:29.3597 switcher argument[1]: '--gamepath=/Applications/World of Warcraft/'
01:05:29.3598 switcher argument[2]: '--game=wow_enus'

#-----------------------------------------------------------
# System started at 2012-10-11 01:42:32.0918
# system:
#-----------------------------------------------------------
01:42:32.0926 switcher argument[1]: '--gamepath=/Applications/World of Warcraft/'
01:42:32.0927 switcher argument[2]: '--game=wow_enus'

#-----------------------------------------------------------
# System started at 2012-10-11 01:42:40.8968
# system: MacBook Pro
#-----------------------------------------------------------
01:42:40.8973 switcher argument[1]: '--gamepath=/Applications/World of Warcraft/'
01:42:40.8973 switcher argument[2]: '--game=wow_enus'
World of Warcraft Launcher.app
World of Warcraft-64.app

You're missing the World of Warcraft.app file (32-bit client). Any idea where this is at? I know sometimes some users drag this to the desktop inorder to make a shortcut, but this breaks the game.

A healthy full folder should be this:

Cache
Data
Interface
Launcher.db
Logs
Movies
Screenshots
SetupOSX.mpq
Updates
WTF
WoW.mfil
WoW.pfil
WoW.tfil
World of Warcraft Launcher.app
World of Warcraft-64.app
World of Warcraft.app

From your switcher log, it may indicate its pointing to the right path, for World of Warcraft.app is missing.
i think the issue may be fixed.

the World of Warcraft.app was sitting in the updates folder, so i moved it back into the position you have shown above and now the patch is downloading, so looks like all is fixed.

thanks for your help
I was having the same issue as all of you. I didn't see this thread until I uninstalled and I'm currently reinstalling now, hopefully that fixes it as well? Besides being a big waste of time, does anyone know?
I'm confused why it only messed up our games after the patch... The hot fixes make it seem as if we shouldn't have been able to play even if there wasn't a new patch. That's what's confusing me the most. If our files are in the wrong spot why did it affect us all at the same time?

Join the Conversation

Return to Forum