Serious graphics issue mac - no fix found :(

Mac Technical Support
Ever since the update of MoP I have had this graphic issue where my graphics are blue?

I have looked online everywhere and cannot find a single fix and I have tried deleting the game and redownloading it and did not solve it either.

I am running WoW on a late july 2011 macbook pro with an Intel HD graphics 3000 384mb graphics card (unfortunately but never had a problem prior MoP...)

here is a photo of my issue:

If anyone can help me at all I'd really appreciate it :( I seem to be the only one with this problem.
What are your system specs?

    1. Launch World of Warcraft and log in.
    2. Put World of Warcraft into Windowed Mode if it is not already in Windowed Mode.
    3. From the system menu bar, select Help > Copy Support Information:
    4. Paste the contents of the copied system information here (Command-V)

This sounds like you're running an older OS build, as I remember with that chipset, there was an issue with 10.7.0 drivers causing this issue. Have you ran Software Update to see if you have any pending software update?
Hello Machkhan,

I ran a software update and only had an update for iTunes and iPhoto,

I've altered my graphics when logged on as well as reset them too and still nothing.

Here is my support info:


System Software Overview:

System Version: Mac OS X 10.7 (11A511)
Kernel Version: Darwin 11.0.0
64-bit Kernel and Extensions: Yes
Time since boot: 3 days 19:57


Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro8,1
Processor Name: Intel Core i5
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 4 GB
Boot ROM Version: MBP81.0047.B0E
SMC Version (system): 1.68f96
Sudden Motion Sensor:
State: Enabled


Intel HD Graphics 3000:

Chipset Model: Intel HD Graphics 3000
Type: GPU
Bus: Built-In
VRAM (Total): 384 MB
Vendor: Intel (0x8086)
Device ID: 0x0126
Revision ID: 0x0009
Color LCD:
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Display Connector:
Status: No Display Connected
Display Connector:
Status: No Display Connected
Display Connector:
Status: No Display Connected


Input Source ID:
Keyboard Layout: ANSI
10/02/2012 04:21 PMPosted by Mithòs
System Version: Mac OS X 10.7 (11A511)

This is the issue. I'm not sure why Software Update did not say there was an update, as the latest version of 10.7 is 10.7.5.

Can you try to download this combo update and see if it works? This should load all updates and drivers from 10.7.0 to 10.7.5.
Alright, Yeah I'm not sure what happened either, I ran it again and it said it was up-to-date :/
I downloaded it on apple support and I'll check back if it works!

Thank you very much :)

Join the Conversation

Return to Forum