Potency quest: Mist Horror not spawning

Quests
I am attempting to complete the "Potency" quest in patch 5.1 on my 85 Alliance warlock. I am able to kill the 8 Mist Creepers, but the Mist Horror does not appear no matter how many more Mist Creepers I kill. I have not left the quest area. I have a 3 year old iMac and am running in 64-bit mode.

I have tried dropping and redoing the quest to no avail. I then tried dropping the quest, disabled all non-Blizzard add-ons, rebooted and got the same results.

Previously I done the quest successfully on 3 or 4 other 85s.

Any useful suggestions?

PS. Should the quest be renamed Impotency for me?
I just had this same issue but was able to fix it. I had to log completely out of the game and when I came back in, I had the orange mist showing on my screen. If you already have all 8 killed, run out of the quest area so the orange mist disappears and run back in. Kill one more Mist Creeper and the Horror should spawn.
Thanks, Shirduk. That fixed the problem. Much appreciated.
this helped my husband and i too Shirduk. thanks for the tip!
11/28/2012 09:56 AMPosted by Shirduk
I just had this same issue but was able to fix it. I had to log completely out of the game and when I came back in, I had the orange mist showing on my screen. If you already have all 8 killed, run out of the quest area so the orange mist disappears and run back in. Kill one more Mist Creeper and the Horror should spawn.


this fixed my problem too, thanks a lot Shirduk!
I can also confirm..

Would also like to state that you must LOG OUT of the character /reload does not work .
I actually just ran back to pearlfin (for a safe place to alt+tab to net) and after reading this I headed back in (to log out in there) and as I did so he spawned. Thanks for tip! and before logging try running out of the area real quick (if you're mounted)
Just did this on my mage as soon as I killed the first one I left the are as soon as I left the mists buff appeared went back killed 8 more horror spawned.
Brotips above didn't work.

Tried to get out and get back to mist area of effect and killing about 3 more mob.
Tried to logout, close WoW client and reopen, sign in, and yet nothing worked.

=/
thanks Shirduk that helped complete the quest
Fixed the problem, thanks for the tip.
I just had the problem for the first time too. I did not have the problem on my other 3 toons so far. But when I read the above tips, I ran to Lorewalker Cho's area to turn in the 2 completed quests and just out of curiosity I went back to the swamp area and the orange mist suddenly appeared on my screen. I had to kill 2 more for a total kill number of 12 (10 before looking here for help and 2 more after running to Cho's area and back out). So just leaving the swamp area fixed it for me. Thanks to Shirduk and to Misericord for suggesting an alternate option.
Shirduk's suggestion helped me, thank you!
yay ty, loggin out n bak in agen fixd it
also GG blizz u no how to make games pro
Thank you! I was going crazy trying to complete this quest. This worked perfectly! Hopefully this quest will be fixed.
Same issue as everyone above.

Same fix worked for me.

Join the Conversation

Return to Forum