Any one unable to log in now error 122?

Garrosh
Post Limit:
Hey just tried login blizz says garrosh is up but im getting error 122 anyone else getting this or is the server up and im just a noob?
i cant either..
I hear ya. I can't get on either. I get the same error.
I just hope it's not doing that until the scheduled maint. is over.
Looked up older posts about the same problem and it seems to be the authentication servers. If i had to guess, you previous posters have the authenticators?
Don't know much about these systems or anything but i have full connection to the internet (obciously im posting) and all the support stuff is telling me to check my connections and such... Although i wouldnt be able to reach those support pages if i didnt currently have internet connection so im confused. Seems like it's OUR fault that their systems dont work sometimes, according to their support at least.
well its 2/7/13 and I am now experiencing not being able to sign onto wow. At the advice of a GM to correct my "lag & connection errors," they advised me to delete the wow files: WTF, interface and Cache. Now not only can I not log in (which sends an automatic disconnect to me) but also it is extremely long to connect to wow. I eventually did log into wow only to realize that i have no NPCs, every other toon is lag running in place and I am unable to activate mounts or spells.

Join the Conversation