Fullscreen vs Windowed fullscreen

Games, Gaming and Hardware
I have noticed, that ever since I upgraded from my old HD4870 a year and a half ago, that I get stuttering in ANY game that runs in regular fullscreen mode. In Source engine games particularly, it would report that I had 60fps but would look really jumpy. The effect actually looks quite similar to microstuttering, even though I only have one video card (using an HD7950 right now). With the Source engine, I was able to fix it by either going to windowed fullscreen mode (Portal 2), or putting +fps_max 61 in the launch options for the older games that didn't properly support windowed fullscreen. Windowed fullscreen fixed this issue for WOW too.

The latest games I've had trouble with: Morrowind, Oblivion, and Skyrim. Unfortunately these don't support windowed fullscreen at all natively, but I found a neat little utility called Gamecompanion that will remove the border if you put it in regular windowed mode. Skyrim runs decently on ultra on my system, but it is jumpy at times when it shouldn't be. Once again, windowed mode fixes this problem entirely and it's MUCH smoother.

The last video card I used that could do fullscreen without this type of stuttering was the HD4870. Ironically, windowed fullscreen mode gave me LESS performance on that card, while it seems to increase performance on the newer ones. I'm curious if anyone else has run into this, and if anyone knows what the causes of it might be.
Vsync

/thread
Vsync

/thread


Vsync is on, I always keep vsync on in all those games. That's not it.
Vsync

/thread


Vsync is on, I always keep vsync on in all those games. That's not it.

Have you given it a try with it off?


Vsync is on, I always keep vsync on in all those games. That's not it.

Have you given it a try with it off?


Yep, doesn't help. Portal 2 for example jumps up to over 300fps and still looks jumpy if it's in fullscreen. In windowed fullscreen, with vsync on it looks fine. With vsync off I get screen tearing (expected at 300fps), but no jumping. It's got nothing to do with vsync.

This happened on a Phenom 2 with an HD6870, but then I built a new system (new motherboard and all, using FX-8350 and HD7950 now)...but it has the same issue. And the old Phenom 2 system didn't have that problem with the HD4870.

I wouldn't care too much...since windowed fullscreen fixes the problem, but there are some games where it is a royal pain and requires ugly hacks to get windowed fullscreen enabled.
Hmm I'm wondering if it has something to do with the monitor's sync and nothing graphic wise.
02/03/2013 04:27 PMPosted by Amksed
Hmm I'm wondering if it has something to do with the monitor's sync and nothing graphic wise.


2 different monitors. With the Phenom 2 system, I used an older Samsung LCD from 2006 (no DVI, just using VGA, etc). 1280x1024. When I upgraded I got a new monitor too, a newer LED-backlit LCD, 1600x900 with DVI. I really don't think it's the monitor.

I upgraded to Win7 before I changed out the video card for the first time. So I never got to try the HD6870 with XP. But considering the same thing has happened with 2 different monitors, 2 different video cards (6870 and 7950), 2 different motherboards (an AM2+ one with DDR2 RAM, and an AM3+ with DDR3), 2 different CPU's (Phenom 2 560, and FX-8350), the ONLY thing they have in common are the AMD video drivers. But this has persisted since something like 10.something (which was current when I got the 6870), to 13.1 (which is current now). And it's happened on both Win7 and Win8 (both fresh installs). It started the instant I swapped out the 4870 for a 6870 in my old system. The odd part is, the 6870 and 7950 are a TOTALLY different architecture (VLIW5 vs GCN). It think the 4870 was also VLIW5, but I'm not sure.

And it's obviously not a hardware probem since I get extremely good performance in windowed/fullscreen, but not in fullscreen. It LOOKS just like microstuttering with 2-way SLI or Crossfire, but I only have 1 video card so it's not actually microstuttering. And in Portal 2's case at least, it still reports that it's getting full 60fps (with vsync on), but it just LOOKS really stuttery. I don't know how to check the fps in Skyrim.

I had forgotten about this problem for the longest time, since I just started running windowed/fullscreen (which will be necessary if I ever add a second monitor anyway) for everything. But then I got Skyrim, and it didn't support windowed/fullscreen, so I had just been running it fullscreen. Then I noticed it looked REALLY jumpy compared to my roommate's nearly identical system (his is an FX-8350 also but he has a GHz 7970 instead of 7950). That's when I remembered the fullscreen issue, and I found a way to manually edit the .ini file to give me 1600x900 windowed, and then used a program called Game Companion to get rid of the window borders in Skyrim. And now it run ultra flawlessly just like my roommate's system.
I've been thinking about it more, and I'm wondering if (in some cases, Skyrim at least) if my video card is using 2D clocks when in fullscreen. But unfortunately, that is very difficult to check...because by the time I alt-tab back into CCC to check the clock speed, it's at 2D clocks by then anyway.
I had a video card that did that. It took me a long time to figure out, but it was stuttering because it kept switching back and forth between modes (switching the clock speeds). You can check by playing with the overclock settings.

Visit a web page that has a flash ad. That should let you see in CCC what two speeds the card is flipping between (you might have to scroll up and down on the page to get it to switch speeds). Then try setting the overclock speed to match your base speed, so it doesn't keep jumping up. This means you can't overclock your card, but at least it should fix the stuttering.
I had a video card that did that. It took me a long time to figure out, but it was stuttering because it kept switching back and forth between modes (switching the clock speeds). You can check by playing with the overclock settings.

Visit a web page that has a flash ad. That should let you see in CCC what two speeds the card is flipping between (you might have to scroll up and down on the page to get it to switch speeds). Then try setting the overclock speed to match your base speed, so it doesn't keep jumping up. This means you can't overclock your card, but at least it should fix the stuttering.


Um, that's not going to work. Base speed is 300 MHz GPU/150 MHz RAM. Normal gaming speed is 900 MHz GPU/1250 MHz RAM. It is only supposed to go down to 300 when in 2D mode. And I'm not certain that it IS going to 300 when I'm running in fullscreen.
If you want to track clocks and usage of your video card while gaming, download gpu-z and open it to the sensors tab. You get a graph of the last several minutes that shows gpu speed, mem speed, and various temps. You will be able to check if its using (or even just occasionally throttling) to 2d clocks in minutes.

http://www.techpowerup.com/gpuz/
If you want to track clocks and usage of your video card while gaming, download gpu-z and open it to the sensors tab. You get a graph of the last several minutes that shows gpu speed, mem speed, and various temps. You will be able to check if its using (or even just occasionally throttling) to 2d clocks in minutes.

http://www.techpowerup.com/gpuz/


Ok I finally had some time where I could mess with this. According to GPU-Z, my GPU is NOT going down to 2D clocks in fullscreen mode. Clocks are correct, and the same as they are in windowed/fullscreen. But I still get really bad stuttering, where it plays flawlessly in windowed/fullscreen. It looks *exactly* like microstuttering with a 2 GPU setup, but I don't have 2, so it can't be actual microstuttering.
Ok, this is weird. Diablo 3 runs fine on regular fullscreen, so does Starcraft 2. But every single other game I've tried suffers stuttering on fullscreen, but runs smoothly windowed/fullscreen.

Join the Conversation

Return to Forum