Stuck on "Updating Blizzard Update Agent"!!

Mac Technical Support
I have been trying to load WoW for the last 2 hours, the launcher starts up and has a message saying "Updating Blizzard Update Agent", has been stuck at about 60% for the last hour. I read the prior forum posts and deleted the Battle.net folder in /User/Shared/ folders and sent it to the trash, but no success.
Help would be greatly appreciated, thank you.
This could be software stopping the launcher. You have done the first thing I would have suggested.

Check that Antivirus, Third Party firewall, Real-time Antispyware, Net-Nanny type software is disabled while you get download.

Also there have been reports that a video card OC program called GURU II can block launcher.
Hmmm.

If you're on a Mac you should be in the Mac Tech Support forums. Maybe if I hang out the Zombie Sheep Signal this thread will get moved there (it's made of balsa and string and has mutton on it)

I would try updating the battle.net tools manually :

http://patchup.info/Blizz/tools/Mac/
I have a solution it worked for me. just follow the directions in my post link. Hope this helps.

http://us.battle.net/wow/en/forum/topic/7885318505
I have a solution it worked for me. just follow the directions in my post link. Hope this helps.

http://us.battle.net/wow/en/forum/topic/7885318505


That only sweeps the issue under the rug.

Bypassing the launcher means you may not be aware of updates to the Agent , Launcher and game files.

Effectively your avoiding the issue rather then properly solving it.
At the end of my linked post, i wrote till there is a fix.... Hey atleast you can play..enough said....
02/10/2013 08:56 PMPosted by Kreám
At the end of my linked post, i wrote till there is a fix.... Hey atleast you can play..enough said....


But when there's a patch, he'll be right back where he started unless he fixes it for good.

Logosh, have you also tried deleting the /Users/Shared/Blizzard/Battle.net folder at the same time you delete the /Users/Shared/Battle.net folder? You may also need to delete the WoW.mfil file in your World of Warcraft directory when doing this, to force the launcher to act as if it's doing things for the first time. This combination usually causes it to find and use the correct download links, assuming none are corrupt on Blizzard's end.

________________________________________________
Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
its not working for me
Gah none of this is helping someone Plz! :(
Hmmm.

@ The last two posters - are you getting stuck on Updating Blizzard Agent ? Or just stuck at the launcher in general.

There was a bug fix patch today.
________________________________________________
Mac Tech Support Cerulean Cosmic Bovine from NZ
Not on active forum posting duty from Fri 6 PM NZST to Sun 6 PM NZST (IRL Work comes first)

https://twitter.com/bluspacecow
i started playing wow after 3 years. Fine last few days. decided to get Mists so i deleted everything(uninstalled) got Mists. After trying to agree with the agreement. it states communication error. So techy said to get battle.net setup but it's only at 1/3 update and it's been 4 hours

Join the Conversation

Return to Forum