Flames of Xoroth bug

Warlock
Anyone else have this problem that when they summon their pet using Xoroth that they always get the wrong one? At one point I switched from Demo to Destro, had the blueberry out just before and cast Xoroth and I got the Felguard, not bad at all but it disappears about 20s later. Now no matter what I start a BG off with all I ever get later is the Imp...

Any known fixes?
Hmm, if I've already sac'd it before entering the BG I don't tend to summon it just to sac it again. That may help with the BG/RBG thing but it's still kind of strange getting a Wrathguard/Felguard sometimes.
I am so embarrassed this doesn't normally happen.
ive been able to pull out a wrathguard for a few seconds and do some pretty good dps. Unfortunately, blizz was smart and limited it to 20 seconds.

For me, when switching from demo-destro, it remembers my last pet out. So by far itll be wrathguard.
If I enter a BG or 5 man and don't resummon my current Demon before using FoX, it will bring out my Imp.
Bumping this old thread because this bug still happens to me. I submitted a bug report just the other day in fact. I am sure I summoned my Observer and then, when he died and I used Flames of Xoroth, my Imp popped out, ready to party.
Bumping this old thread because this bug still happens to me. I submitted a bug report just the other day in fact. I am sure I summoned my Observer and then, when he died and I used Flames of Xoroth, my Imp popped out, ready to party.


Not a bug, system limitation. Zoning resets the last pet summoned variable.
I've had this happen even after switching my pet while zoned into a raid/dungeon. Sometimes you don't even get the Command Demon ability to work properly after using FoX.
11/12/2013 07:34 AMPosted by Annorroth
Bumping this old thread because this bug still happens to me. I submitted a bug report just the other day in fact. I am sure I summoned my Observer and then, when he died and I used Flames of Xoroth, my Imp popped out, ready to party.


Not a bug, system limitation. Zoning resets the last pet summoned variable.


Rather crippling limitation. Given the description in the spell tooltip, it shouldn't behave this way, so it constitutes a bug. They need to re-word the tooltip to be more accurate or fix the underlying system work properly in all situations.

Join the Conversation

Return to Forum