Problems with shift, ctrl, and alt modifiers

UI and Macro
Post Limit:
Alright..
So i'm trying to make modifier macros for my rogue and i've run into a brick wall.
My first macro is:
#showtooltip
/cast [stance:0, nomod] Hemorrhage
/cast [stance:0, mod=shift] Backstab
/cast [stance:1/2/3, nomod] Ambush
This works great with a shift modifier...

Now I'm trying to make a double modified macro like this:
#showtooltip
/cast [nomod]Eviscerate; [mod=shift]Slice and Dice; [mod=ctrl] Recuperate

The shift part is working fine but whenever i try and press alt or ctrl, it simply acts as if I'm pressing shift. It seems to me like the game is treating them all as one button. Also when i press ctrl or alt, the shift modifier for my first macro activates...
I seriously don't know what do do!!! Plz help meeee
/cast [nomod] Eviscerate; [mod:shift] Slice and Dice; [mod:ctrl] Reucperate

try that
It's still acting as if my shift, ctrl, and alt buttons are all the same.
For instance, in the first macro, Backstab will cast even if i press alt or ctrl instead of shift.. Make sense?
Also, i've deleted any keybinds having anything to do with shift alt or ctrl
well to be honest you can remove the nomod from the line i put in, but it should be working. for the first macro you are going to have to wait for someone a little more experienced in stance macros then i. if i was to try anything with the first macro it would be

/cast [stance:0] Hemorrhage; [stance:0, mod:shift] Backstab
/cast [stance:1/2/3, nomod] Ambush

if you are using additional keys from a keyboard or mouse like a naga remember modifieirs and the button can be counted as a completely different button, ie: shift + 1 on a naga is end on your keyboard.

if you are just editing your own macro (not copying mine) then remember to put a space after the requirements [mod:shift]backstab for instance should have a space between the ] and spell.
Honestly i don't think it's a problem with the macro itself...

Like I said, it seems as though my ctrl, alt, and shift buttons are being treated as the same thing with no distinction between them..

For example, in the 1st macro, it works fine. It uses hemo with no modifier and ambush in stealth. It also uses backstab when i press shift. BUT, it will also use backstab if i press either alt or ctrl. Know what I mean?
i'm afraid i have not experience that problem personaly, have you attempted turning off all addons for a moment to see if the macros work without?
Yeah..
well we can see if the problem is something with the macro or just an error somewhere else. try a /cast [mod:ctrl] low cd spell; other low cd spell
you're using an equals sign, which I assume makes everything to the right of it inside the brackets invalid, so the input is being read as simply [mod]. use the colon as Drakownis suggested in his first post.
i'm sorry what i am trying to say is there might be a catch in the logic but without a rogue of my own i can simulate the same conditions so i can fix it. having others explain an issue they are having is very difficult to diagnose. from everything i can tell those macros should work, since they are not i was hoping to test other possibilities to eleminate the seemingly obvious while i went over the macros again in my mind.
i'm sorry what i am trying to say is there might be a catch in the logic but without a rogue of my own i can simulate the same conditions so i can fix it. having others explain an issue they are having is very difficult to diagnose. from everything i can tell those macros should work, since they are not i was hoping to test other possibilities to eleminate the seemingly obvious while i went over the macros again in my mind.
you talking to me? i was saying your macros should work (with corrected spelling), the OP just wasn't using the actual syntax you used ( [mod=ctrl] instead of [mod:ctrl] )
no i was talking to op, we were posting at about the same time :)
Also, i've deleted any keybinds having anything to do with shift alt or ctrl

Go into interface options and make sure ctrl or alt are not assigned as self or focus cast keys.
Do as Sedivy says above and use this cleaned up versions of the macros.

/cast [noform,mod:shift] Backstab; [noform] Hemorrhage; Ambush

/cast [mod:shift] Slice and Dice; [mod:ctrl] Recuperate; Eviscerate
Hi OP, I am having the exact same problem as you were and I am wondering if you ever fixed it?

Thanks
Bump
1) It is highly unlikely that the OP will be returning to this thread to help you with your problem.
2) Don't bump a thread 60 seconds after you've resurrected it from months back -- That's just bad forum etiquette.

If you have an actual problem, then I suggest you create a brand new thread stating what the problem is with detail and one of the macro gurus will assist you as soon as one is available.

Be well.
OP descrbed my troubles perfectly which is why I decided to try and bring this back.

And yeah it is an "actual problem".

Join the Conversation