Always logged in

Mobile Bug Report
Post Limit:
Hello I am having problems getting remote chat to log out. I have even removed the app from my iphone and yet the guild rosters always shows me as being online as remote chat.

With my iphone completely turned off and with no more wow armory app on my phone it still shows me as being online!

What can I do please?
What can I do please?

A sever restart should correct this. If it doesn't get corrected by itself before then.
Tinkrashi is correct. If this persists, please let me know and I'll look into it further.
Just logged in after the downtime, I'm on my alt and Gnosk is still logged in under remote chat.
Still happening.
I've forwarded this up to a technician to look into.

Can you clarify is you're stuck as Online in WoW, Online in Mobile Armory, or Away in either WoW or Mobile Armory? You'll be able to tell based upon the icon by your name in the Guild Roster:

Green dot = Online in WoW
Green speaker icon = Online in Mobile Armory
Yellow dot = Away in WoW
Yellow speaker icon = Away in Mobile Armory
having the same problem.. cleared all data and all that before deleting it but im showing up as online with it still.

yellow speaker icon next to my name on roster tab in guild..

edit: just tried restarting game and now its showing as the green speaker icon
The icon is yellow speaker. Also it seems to log on and off. I just logged on and Gnosk was online (I was on an alt) but he is now offline.
Go to Guild Chat with the character that is experiencing the issue, login, and then sign out of Guild Chat (not the app itself). Once you've confirmed that you're offline, log out of the app.

If you signed into multiple devices (phones, tablets, portable music devices, etc.) with your account, you may need to perform these actions per device.

I very rarely encounter this myself but these steps have been proven to work in most cases, as this should hit all of the WoW status logic related to logging you out and placing you into an Offline state.
Logged in to the app
Logged in to guild chat.
Tapped on chat icon on top left, tapped on Offline
Logged out of the app
Removed my login and pass from the boxes.
Unticked the box for "remember me"
Exited the app
Killed the app process
Uninstalled app and removed it from my phone.

I can still see in the game where my character is logging in and out repeatedly. I do not own any other devices that would run this app.

Running Android 4.2.2 on GSM Unlocked Samsung Galaxy Nexus with T-Mobile.
We're looking into addressing some issues with presence, but not sure if this would address your particular scenario. Do you keep yourself logged into the WoW Community site or any other part of Battle.net website?

I've forwarded your account to a technician to take a look at in the meantime.
We're looking into addressing some issues with presence, but not sure if this would address your particular scenario. Do you keep yourself logged into the WoW Community site or any other part of Battle.net website?

I've forwarded your account to a technician to take a look at in the meantime.


Not normally, no. The Battle.net site has kept me logged in for this session while I've waited for you to reply. But normally I never log in from my PC browser unless I need to get into my account, which is not very often.
This is a tough issue to crack. We're exploring all types of potential fixes, including server and client updates. No guarantee or estimate on a fix but we are seeking a solution.
Is this still a problem for anyone in this thread? We haven't noticed this particular issue for some time now.
It is an issue still for me, but only since I got an iphone. It never happened on my android devices.

I've tried all the steps here but my characters still show as logged in via remote chat.
It is an issue still for me, but only since I got an iphone. It never happened on my android devices.

I've tried all the steps here but my characters still show as logged in via remote chat.


If you switched to a new phone, it's very possible that you have an active session open on your old Android.

If you still have access to the old device, reinstall the Mobile Armory on it, login, go to the Guild Chat page, toggle Online to Offline (may need to wait for it to connect first), and then log out of the app entirely.

Do this for each character that is affected.
Its been an issue for me too on my main Shunomi and also i might add since i havent seen anyone mention this but no one can invite me to a group when i on Shunomi because of the remote chat icon beside my name so i have to invite them but its hard when raid calls are going for the sha or anything no one can invite me. Ive done all the steps and talked to multiple game masters inside of wow itself i dont use the app and now only keep it on my phone to log Shunomi out when he logs himself in even though my wireless is switched off of my android and it even happens when i uninstall the app. I was told by a game master to report to this forum so i am doing so after about 1 week of this happening.
Have you tried the troubleshooting steps above?

Join the Conversation