Unable to establish connection to server

Mobile Bug Report
1 2 3 6 Next
Anyone else unable to login to the mobile armory app. I'm getting this message all day from both wifi and 3G.
I also have this problem on a daily basis. On wifi and 4G
I've had the same problem today as well. On 4G and on the wifi network I'm using to post now.
Me, too.
Have been getting better results accessing the AH via phone's web browser.
Same here.
Im having the same issue. Worked fine till after lunch. I even contacted my isp and checked out my cable modem logs. Nothing blocking it. Must be something on the server side today.
I have the same problem, seem to be down for well over an hour now.
yeah having same issue, was wondering what was wrong
Same here. No access.
I'm having the same problem, lost a couple of auctions since I couldn't log in to mobile armory. It's been down for several hours, have tried WiFi at home and in-laws and 4g and 3g.

{EDIT}: This is through Android version.
I can connect to Europe and Asia but not Americas LOL
I've got this problem too I can't connect even when i have great wifi
Cant connect either. Been trying most of the day. Used two different wifi networks (home and work) plus my 3G connection. No dice. Even tried deleting the app and reinstalling.

Samsung GS3 on the Sprint network.
I have had connection problems off and on for a few days. Today I can't connect at all.

Motorola Droid Razr
Home Wi-Fi and Verizon 4G both have the same problem
mines been down since yesterday.

keep getting unable to establish connection.. now im getting a timed out error.

wifi and 3g.
Same deal for me, multiple devices, isps, and time of day. I can connect to Europe and Taiwan though.
Having the same issue here logging into the Mobile Armory.

Like the other poster stated, I can connect to Europe, but not to Americas.

The issue has been affecting me for the past 3 hours or so, can access features via web version of Battle.net.
Was able to log in this morning and early afternoon (EDT). However, since then I have been receiving the same messages. Have tried resetting my phone, router and using only mobile network 3G/4G.
Getting an error for last few hours that it is unable to establish connection. My friends' are the same way.
Same here.

Join the Conversation

Return to Forum