Log-in Glitch on Battle.net Sites

Website Bug Report
1 2 3 8 Next
I've tried clearing cookies, tried rebooting computer after clearing cookies.. pretty much done just about everything browser related.. but...
I keep getting partially logged out whenever I close out of the battle.net sites (namely D3 and WoW), and I have to click on the "Sign in" link each time on the sites individually.
It doesn't matter how long I've had the tabs/windows closed, it partially signs me out.
As I said, I've cleared my cache, cookies, etc on the browser.. but no dice regardless.
This just recently started happening to me as well. I have to relog in each and every time I leave the Bnet site via closing the browser window out completely. I end up relogging in anywhere from 5-10 times a day depending on how often I pop into the forums or the armory.

This is definitely not how it used to be until the last two weeks or so, give or take.
This just started happening to me as well, just started today. Good to know im not alone
been going on for 3 days for me as well, really getting annoying
Been happening to me for almost a week, getting annoying ;s.
Been happening to me for almost a week, getting annoying ;s.


was able to get a hold of them on facebook they was nice enough to say they would look into it( I sort of wish this section was patrolled more often)
sites now demanding a password every single time now!
Have been having the exact same problem for 2 weeks now where it forces me to login 60% of the time I go on battlenet. Starting today however it started asking me for my login info every single time I get on. If this was an attempted fix to the problem I can guarantee it made it worse.
Have been having the exact same problem for 2 weeks now where it forces me to login 60% of the time I go on battlenet. Starting today however it started asking me for my login info every single time I get on. If this was an attempted fix to the problem I can guarantee it made it worse.


they are looking into it they said, told me that the techs have gone home already so they will have them dig deeper tomorrow, also told them this issue comes up every few months. so maybe they can look into that too so it stops happening.

I suggest people post information on what browser they are using and what OS and any browser related addons.

I am using Firefox 20.0.1 with noscript and adblock plus as well as windows 7 home premium 64bit.
I use firefox 20.0.1 with noscript and adblock also. I seem to have to log back into the website a few times a day although sometimes it lasts the whole day.
I use firefox 20.0.1 with noscript and adblock also. I seem to have to log back into the website a few times a day although sometimes it lasts the whole day.


just heard back from blizzard an hour ago, they said the techs are networking the issue now, hopefully they will have something new to tell me in a few hours
I use firefox 20.0.1 with noscript and adblock also. I seem to have to log back into the website a few times a day although sometimes it lasts the whole day.


Same. I am getting randomly logged out even with the tabs open and am forced to log back in with my password. This started happening within the past 2 days for me. Prior to that I logged in about once a month as long as my IP address did not change.

Thanks for pointing this out Anka! Glad it is not due to attempted unauthorized account access or something. I was beginning to wonder.

Edit to add that some threads I have already visited are not staying marked as read, despite there being no updates to them. Not sure if this is related or not, but it seems possible.
Just adding my two copper.

I'm using Google chrome fully updated. No add-ons. Norton 360 up to date. Same as everyone else, about a week ago started needing to log in every time I came back to the page, yesterday started asking for email and password, but no authenticator.
Just adding my two copper.

I'm using Google chrome fully updated. No add-ons. Norton 360 up to date. Same as everyone else, about a week ago started needing to log in every time I came back to the page, yesterday started asking for email and password, but no authenticator.


Good point, its not asking for the authenticator either.

Also here is the answer I got from blizzard about this issue.

I was unable to dig up anything concrete about the issue. Let's play it by ear - if you continue to see that this happens, please let us know through this channel or respond to the ticket you've created through battle.net. We'll certainly do what we can to assist.

I would suggest you guys open tickets and complain as well.
I am being asked for my authenticator. This is really really irritating. I am at home at the same PC that I have been on since 2009. Within the past two days it is asking for my login and Auth every few hours. I am not closing tabs or moving to a new location. I am sitting here..tabs open.. and suddenly asked for the login and auth. Hopefully they fix this...
I am being asked for my authenticator. This is really really irritating. I am at home at the same PC that I have been on since 2009. Within the past two days it is asking for my login and Auth every few hours. I am not closing tabs or moving to a new location. I am sitting here..tabs open.. and suddenly asked for the login and auth. Hopefully they fix this...


starting to annoy me to, hopefully they find the cause soon!

this issue seems to happen every few months
Today I am having even more fun! I managed to stay logged in to the WoW forums overnight despite closing the tabs. That was great. Grabbed my coffee and opened a few tabs this morning, one for WoW forums and one for D3. WoW was still logged in but D3 forced me to login with pass and Auth. This is new.... Usually once I am logged in on either of the forums the login persists across to the other.
This is getting REALLY annoying. Please fix it.
Still going on.

No idea why they can not look at recent site changes. I am sure they maintain some sort of information on what and when they change things.

Something they changed recently is causing this issue I would bet.
Count me in the getting logged out club. I am checking the keep me logged in box. I'm running the latest version firefox.

Join the Conversation

Return to Forum