No puedo cambiar región al iniciar sesión

Soporte técnico
Así es, al iniciar sesión debería aparecer un botón que dice región o regiones, no recuerdo exactamente. Este botón aparece arriba del botón "Opciones".

En casa de un amigo dicho botón aparece y puedo iniciar sesión en la región que desee, pero en mi pc no aparece esta opción. ¿A que se debe esto, que debo hacer para solucionar este inconveniente?

Espero alguna respuesta, ya busqué en el foro y no encontré nada que me ayude, gracias.
En la pantalla de login, hace lci en el botón que está ala derecha donde ingresás el mail y te aparecerá el botón.
justamente hago eso, aprieto el botón con la flecha hacia arriba, pero no aparece el botón para elegir regiones, en casa de un amigo si aparece pero no en la mía...

las cosas raras siempre me pasan a mi :(
Quiero agregar algo que tal vez pueda ser la razón, mi monitor es cuadrado (4:3) y el botón podría aparecer fuera del área visible, lo cual sería un bug... lo digo porque probé en otra pc con monitor cuadrado y tampoco aparece. En cambio en la pc que tiene monitor 16:9 si aparece...
Quiero agregar algo que tal vez pueda ser la razón, mi monitor es cuadrado (4:3) y el botón podría aparecer fuera del área visible


Saludos Aleksander. No creo que esa fuera la causa pues yo tambien tengo un monitor cuadrado e hice exactamente los mismos pasos y a la primera vez me salio el recuadro de [REGION]. Este recuadro te debe aparecer a la izquierda de la pantalla encima del recuadro [OPCIONES].

Si aun sospechas de que la causa sea el "aspect ratio" del monitor entonces prueba el juego en varias resoluciones hasta que puedas ver el recuadro. Yo manejo la resolucion de 1024x768 por si quieres tomar esa resolucion de referencia.
bueno he intentado de todo, cambios de resolución, borrar el archivo variables etc. y el dichoso botón no aparece, así que no se que hacer...

les dejo una captura:
http://img585.imageshack.us/img585/2763/screenshot2013042316534.jpg
Destilda lo de recordar cuenta.
Probaste esperar un momento sin iniciar sesión, a mi en un inicio pensé que tampoco me aparecía la opción pero lo deje un momento, aproximadamente 5 segundos y me aparecio
Probaste esperar un momento sin iniciar sesión, a mi en un inicio pensé que tampoco me aparecía la opción pero lo deje un momento, aproximadamente 5 segundos y me aparecio


Si esperé unos segundos y no aparece, lo minimicé esperé varios minutos y tampoco aparece.
Destilda lo de recordar cuenta.
Destilda lo de recordar cuenta.


no hay caso, así tampoco funciona :(

http://img526.imageshack.us/img526/5981/screenshot2013042400100.jpg
mmmm y si dejas el campo de mail vacío?
mmmm y si dejas el campo de mail vacío?


así tampoco aparece, no hay caso, tal vez deba borrar todo y reinstalar pero cuando tenga tiempo... gracias igual por intentar ayudarme :)
No reinstales, espera.

Copia esto dentro de un documento de texto *.txt

<regions>
<region displayname="AUTHENTICATION_SG_REGION" hostname="sg"
allowedProductLocales="all" localesThatDefaultToThisRegion="enSG"/>
<region displayname="AUTHENTICATION_US_REGION" hostname="us"
allowedProductLocales="all" localesThatDefaultToThisRegion="enUS"/>
<region displayname="AUTHENTICATION_EU_REGION" hostname="eu"
allowedProductLocales="all" localesThatDefaultToThisRegion="enGB"/>
<region displayname="AUTHENTICATION_KR_REGION" hostname="kr"
allowedProductLocales="all" localesThatDefaultToThisRegion="koKR"/>
</regions>


Y renombrá el archivo a regions.xml, copia y pega el archivo en c: StarCraft II y el botón debería aparecerte, aunque también antes de intentar esto podés probar esto otro:

Borra la Carpeta Battle.net


Window 7

C:\ProgramData\Battle.net

Windows XP

C:\Documents and Settings\All Users\Datos de programa\Battle.net

Si no ves la carpeta Program Data, habilita la opción de Mostrar todos los archivos y carpetas ocultos.

Después de borrar todos los archivos, vuelve a ejecutar el juego.

Ejecutar como administrador

El juego necesita privilegios de administración para hacer los cambios necesarios.

Haz clic derecho en el icono del juego
Selecciona ‘Ejecutar como administrador’
¡Muchísimas gracias Hayato!

Te cuento:

Intenté primero la opción de borrar la carpeta "C:\ProgramData\Battle.net" pero no funcionó, así que anexé el arrchivo "regions.xml" a la carpeta donde está instalado el juego y esta opción si funcionó :)

te debo una, acá te dejo una última captura:

http://img38.imageshack.us/img38/292/screenshot2013042402445.jpg
Ja ja ja de nada! De todas formas consultaré porque hay que usar ese archivo y no te aparece de manera nativa. Ese archivo se usó para probar el global play antes de que saliera, imaginé que te pdoría servir.
a mi = m daba problemas pero inciaba secion y luego lo cerraba .... esperaba 3 seg y aparecia el boton ...
MRDA, instale el cliente coreano y recién me vengo enterando del documento de Regions.xml

pero bueno, solo perdí el tiempo, Gracias Hayato por el dato
Excelente solucion Hayato. Esta solucion la tomaremos como referencia para futuras consultas sobre este tema.
MRDA, instale el cliente coreano y recién me vengo enterando del documento de Regions.xml

pero bueno, solo perdí el tiempo, Gracias Hayato por el dato


Eh? Pero el juego no requiere que instales múltiples instalaciones de StarCraft II, el botón aparece (o debería aparecer) sin el uso del archivo regions.xml

Únete a la conversación

Regresar al foro