Erro na versão do do SCII

Suporte Técnico
Quando entro no jogo fala q a versão da região que eu estou (America Latina) Não é compatível com a versão do meu jogo . Porem atualizou sozinho.
Segue link da SS abaixo:

http://i.imgur.com/cLX50q5.jpg


Oq eu faço?Obrigado.
Tá dando isso no meu jogo também. Heeelp
Oi Orphen,

Isso é um problema do nosso lado, vou colocar o aviso para todos agora mesmo num tópico fixo. ;)

Junte-se à conversa

Voltar ao fórum