Mavericks GM Firewall issue

Posts: 20
I don't know if you regard the GM release still as beta, but nevertheless I'm seeing HS always asking to allow or deny connections upon launch despite it being on the allowed list in the Firewall settings.

It works but always need to click allow when launching.
Reply Quote
Posts: 9
Same issue here with the version released.

No problem with D3.
Edited by Djabx on 10/26/2013 6:17 AM PDT
Reply Quote
MVP - Technical Support
Posts: 19,123
From my network analysis I can see it opening connections to :

us.actual.battle.net on port 1119

iir.blizzard.com on some port I can't recall right now

A match server on an IP 12.130.247.xxx on port 3724

Try allowing connections to those network addresses.
Reply Quote
Posts: 20
I'm having this issue as well! Gets annoying at times but the game works. I can't get it to go away even though I have it set to always allow connections in firewall settings.
Reply Quote
Posts: 33
I have the same issue with the built in os x firewall on 10.9. From a previous application launch I added it to the firewall list but the game still prompts a decision every time the game is subsequently launched. The game works perfectly fine though. This is running on a Mac Pro 3,1.
Reply Quote
Posts: 20
Same with me running on 10.9 and have it selected to to allow access in my firewall. Running on 13inch Macbook Pro Mid 2010 model.
Reply Quote
Posts: 1
Well, It's because blizzard hasn't code sign Hearthstone.app, maybe we need to wait until the open beta test beginning.
Reply Quote
Posts: 1
I am having the same issue.

Anyone has a solution or a workaround for this? This is really annoying.
Reply Quote
Posts: 3
Happens to me, too. Could someone from Blizzard confirm this is due to the current Hearthstone.app being unsigned, as SilverFox posited?
Reply Quote
Posts: 17
The same issues happening even though battle net client and hs clients are allowed under firewall...there is still a pop up to ask to confirm it !!!
Reply Quote
Posts: 77
same here...
Reply Quote
Posts: 20
This still hasn't been addressed? I'm Hoping its still because we are in beta.
Reply Quote
Posts: 1
This only started happening for me when I upgraded to the latest patch 1.0.0.4243.
Previously I had been running Mavericks without issues.

In addition I added the following to the "System Preferences" -> "Security & Privacy" -> "Firewall" -> "Firewall Options"

"Hearthstone"
"Hearthstone Beta Launcher"
"Battle.net"

Set them to "allow incoming connections".

Regardless; every time I launch the game I have to click "accept" on the "Do you want the application “Hearthstone.app” to accept incoming network connections?" notification.
Reply Quote
Posts: 1
I have the same Problem on my own iMac.
For holidays i travelled home and there i installed the game on my mothers iMac. There i just had to accept on first start. Now there comes no question again.

Maybe a new install is the solution?
Reply Quote
Posts: 14
12/23/2013 03:34 AMPosted by reino
I have the same Problem on my own iMac.
For holidays i travelled home and there i installed the game on my mothers iMac. There i just had to accept on first start. Now there comes no question again.

Maybe a new install is the solution?

She may have the firewall turned off. I've upgraded so many times, I don't remember what the default setting is.
Reply Quote
Posts: 465
Same here. This is also happening for the game Memoir 44 on my Mac.

Running 10.9.1

Firewall settings show that I'm allowing the incoming connections.
Reply Quote
Posts: 9
Same here (Mavericks 10.9.1). Even when I hit "deny" the game still works.
Reply Quote
Posts: 6
Same here as well. Are there any plans on fixing this, or any information on what we can do to stop this annoying popup?

I've tried re-installing battle.net and hearthstone, disabled/enabled firewall, even went ahead and deleted the file /Library/Preferences/com.apple.alf.plist (the firewall settings). I can't seem to get this fixed. I'm guessing it might be because the app is not code signed, as SilverFox has suggested.
Reply Quote
Posts: 224
Hello Fandom,

If you disable the Mac Firewall, the message should go away.
Reply Quote
Posts: 6
Thank you -- I would like not to disable the firewall, as I use my computer on unprotected networks occasionally. Sure, someone who wants to break into my computer and knows what he's doing would laugh at the standard mac firewall, but still, an extra layer of protection never hurt anyone.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]