Play button greyed out.

Posts: 5
cannot click on Play button. I was played yesterday. Don't know what to do, have tried reboot mac, reinstalled battle.net.

Doesn't work
Reply Quote
Posts: 1
This is happening to me as well. I just got the beta today, installed it and the play button is grayed out saying, "service is unavailable in your region" but I'm In US, so I'm not sure whats wrong. Hopefully they fix it because I'm so disappointed I finally got the beta but can not play :(.
Reply Quote
Posts: 11
I am having this same problem as well. It won't let me connect to Battle.net through the Beta Launcher; but I can connect to bnet online and on other games.
Reply Quote
Posts: 4
same issue...pls help
Reply Quote
Posts: 1
I have been reinstalling battlenet and hearthstone everyday for 3 days now. All my other games are launching without any issues. Mac is up to date. Any help would be greatly appreciated.
Reply Quote
Posts: 1
I was having this problem for a sec and then realized I was trying to login with my Battletag rather than my email address! As soon as it detected an @ sign in the username field the blue button lit up. Worked for me, hope it helps anyone else having a PEBKAC error ;)
Edited by Squidhelmet on 10/31/2013 6:57 AM PDT
Reply Quote
Posts: 68
Started getting this even when i try and play Diablo 2 it says you have been disconnected by battlenet, PC though not MAC
Edited by Kiwical on 12/27/2013 12:05 AM PST
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]