Game loses connection during play.

Posts: 53
I have been playing the beta without issue until about 4-5 days ago. It was then that the game would stop allowing commands or show what the opponent was doing without major (what seems like) lag spikes. The software itself still is working fine ( i can still click all the do-dads and access the menu with out delay). I may have a normal first hand, but then the game "hangs" on the opponents turn. Most of the time now the game is lagging so bad that i just have to quit the game. The has almost made the game unplayable.

My connection is wireless on a mid 2011 imac. Nothing has changed in the last couple of days that could be causing these lag spikes.

I wish that there was a connection speed bar like other blizzard games where i could see where or when the lag is occuring. Any help?
Edited by Taoiseach on 11/24/2013 6:24 PM PST
Reply Quote
Posts: 26
I'm seeing the same thing. Makes playing games difficult and beating them nearly impossible. There is no noticeable reason for the drop on my end. Battle.net just loses connection and times me out, or I find myself two turns behind with the turn fuse burning down to the nub. I hope this doesn't make it to the final game.
Reply Quote
Posts: 53
I just booted my imac to its windows partition, and attempted a game. I was able to play a single match completely before the slow connectivity problems returned. This happens during play mode and against the computer ai. I dont want to waste gold on the arena until this is resolved.
Reply Quote
Posts: 15
same issue here, MacBook OS X 10.7.5, every 2nd-3rd game ends up with losing connection, it is impossible playing in the arena, waste of time and gold, hope blizz will fix it "soon".
Reply Quote
Posts: 53
Last night I logged in again, hoping that my issue would be resolved through the maintenance. However, the connection issues seem to have gotten worse. It took me numerous attempts to load up the game, and getting different reasons for not being able to connect each time... First the server timed out, next I got an error message, then it just said there was a problem and to wait a minute before trying again. After trying for about 15 minutes, I was finally able to connect. Only to find the same slow connectivity and server reaction times.

I tried to connect through to Diablo 3 and Starcraft, and both could not log me in.

This whole time I was freely browsing the internet. I am at a loss to what the problem is. Hearthstone was working perfectly a week ago. Now I have not been able to finish a match in over three days.

Please help!
Reply Quote
Posts: 7
Similar issues for me except they are completely random and seem to be sync problems. I will play 10 games with no issue then it will randomly happen for one turn… the next turn it usually fixes itself. When it does happen, it always happens on my turn right after I play a card (minion or spell). I will play the card and if it is a minion it will land on the board but then I can not complete any other actions (attacking with other minions, attacking with my character, or casting a spell). If it happens when I am casting a spell, the spell animation will play very slowly and then nothing will happen.

Usually, my turn will end with the rope catching fire and it will give me all my cards back stating that I can't play anything because it's not my turn. SOMETIMES it will sync back up and a bunch of my actions will complete in rapid succession.

This is a MASSIVE bug imho because every turn is important. Unless you are crushing your opponent, a turn spent doing nothing will lose you the game. 90% of the time I just concede when this happens because it's pointless trying to play catch up once you've lost the tempo and board control...

I should also state that while the game is locked up I can still browse the internet or complete other network-related activities such as downloading a file or streaming music. Finally, I am almost NEVER doing anything else on my network while playing Hearthstone, so I don't think it is interference from other activities.

My guess is that my wireless signal gets a minor hiccup and it completely screws up the game, even though the signal fixes itself...

EDIT: Also, my firewall is disabled on this computer.

MacBook 7,1
13-inch, Mid 2010
Processor 2.4 GHz Intel Core 2 Duo
Memory 4 GB 1067 MHz DDR3
Graphics NVIDIA GeForce 320M 256 MB
Software OS X 10.8.5 (12F45)
Network WIRELESS
Edited by Snafzg on 11/27/2013 10:12 AM PST
Reply Quote
Posts: 1
Same...
Reply Quote
Posts: 1
Same
Reply Quote
Posts: 19
Same... I use macbook pro 13" trough wi-fi. Strange that thing that couple months ago everything was fine. I even tried with wire, the same.
Reply Quote
Posts: 2
Same problem on macbook pro retina mid 2012. Everything else works fine while battle.net connection times out. Generally takes about a minute to reconnect.
Also sometimes some card names are blank, probably another connection issue.
Edited by TearJerker on 7/4/2014 2:09 AM PDT
Reply Quote
Posts: 3
same
Reply Quote
Posts: 1
Same, other Blizzard games don't seem to have this problem which forces Battle.net to time out.

Was every 2-3 games, now it's every game by 5th turn latest. So frustrating :(

Problem since Hearthstone came out
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]