HELP, worked 2 hours ago.... not now....

right, i downloaded Hearthstone for the first time today,

downloaded fine
installed new bnet loader fine
installed hearthstone fine
played fine for 2 maybe 3 hours.

closed the game, got some food....

come back to find i cant get past the first loading screen? (the door)

i have tried ALL "fixes" that people have mentioned,
deleted the client file,
deleted bnet folder
deleted blizzard folder

deleted everything and redownloaded everything
restarted my laptop
reset my connection

my friends on PC are logging in and playing absolutely fine,

but me (on mac) cannot get into the game.

tell me Blizzard, is this a server issue?
let me know so i can stop wasting my whole day finding out what is wrong with my system/install process.

is it a server issue?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]