Firewall issues in OS X Mavericks

Posts: 2
I've seen that every time I open Hearthstone when I have my firewall on, it always prompt me to allow or deny the incoming connections of the game.
I don't know exactly if this is an OS issue or a game issue, but it's kinda annoying.
Reply Quote
MVP - Hearthstone
Posts: 14,978
Did you check the Mac tech support forums for this issue?
Reply Quote
Posts: 6
I have this exact same issue and it's quite a bummer. I've tried re-installing and hearthstone, disabled/enabled firewall, even went ahead and deleted the file /Library/Preferences/ (the firewall settings). I can't seem to get this fixed.

Could you possibly have any recommendations?
Reply Quote
Posts: 1
Same issue here, just wanted to chime in.
Reply Quote
Posts: 3
Same issue on my MacBook Air, but my home and work Macs don't do this. Can't quite pinpoint it.
Reply Quote
Posts: 268
If you're at home, behind a router firewall, there is absolutely no need to enable the Mac Firewall. Never use multiple firewalls, on the Mac it doesn't add any extra security, just makes it harder to use, for example Hearthstone right now.

Just disable it.

Edit: This is an issue by Blizzard, not by OS X.
Edited by xynlovesit on 2/11/2014 9:30 AM PST
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)