Game stuck on initial screen

Posts: 167
Load up the battle.net launcher, press "Play" under the hearthstone menu.
It loads up this screen.

http://img845.imageshack.us/img845/5005/v9ri.png

It does nothing else.
I've left it running for 30 mins, no change. I've tried a fresh install of the battle.net launcher and the full hearthstone game, at the same time.

Notes:
Running version 1.0.0.3749
OS is OS X 10.8.4

Here is a copy of the ConnectLog.txt

process attached
Fri Sep 13 03:53:37 2013 [LOCS] 11010=ERROR_LOCAL_STORAGE_DATABASE_NEEDS_REBUILD <------------------------------------- error
Fri Sep 13 03:53:40 2013 [ACCO] AccountListener.OnSubscriptionActive entity=15693354
Fri Sep 13 03:53:41 2013 [ACCO] AccountListener.OnAccountLevelInfoUpdated account=50914747 currency=DSU region=1
Fri Sep 13 03:53:41 2013 [ACCO] AccountListener.OnSubscriptionActive entity=50914747
Fri Sep 13 03:55:40 2013 [GAME] 3005=ERROR_RPC_PEER_DISCONNECTED
process detached
Reply Quote
Posts: 119
Same problem here. Played it fine for 2 days, changed nothing on my computer then this started
Reply Quote
Posts: 167
Fixed itself.
Reply Quote
Posts: 1
in my case it has a black screen error page

http://img600.imageshack.us/img600/9015/yvj3.png

i give click on

Global_exit

and then games loads
Edited by rasrules on 10/10/2013 7:57 AM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]