StarCraft® II

I want to change the language of my game

Posts: 18
ㅣㅅㄹㅣㄹㅣㅅㄹ ㅣㅏ며아ㅕ아ㅇ아새새ㅏ에기ㄱㅇ겨ㅣㅏ!
Reply Quote
Posts: 1
Hello...

I bought the game in latin america so it's in spanish... I'd like to play it in english so i downloaded the USen client, but it's restricted to starter edition only, doesn't let me loggin in my full standard account.

Anyone have a solution, please?
Reply Quote
Posts: 27
Anyone got an answer for this? i uninstalled the game, downloaded the us version and my client still is in awful latin american spanish...tried with the variables and nothing...any other sugestion? you guys dont even know how awful the latin american spanish version is...please
Reply Quote
Posts: 9
just do what the support guy told u dude its so easy... just in the variables .txt change esMX to enUS.. and ur client will download english pack about 280mb and vuoala
Reply Quote
Posts: 1
It's unfortunate to say that the language restriction to specific regions is an epic fail on blizzards part. I was raised in America but working in Korea. Got tired of playing the game with a dictionary lol
Reply Quote
Posts: 1
Follow the workaround below to return your game client’s language settings to their original defaults.

Locate the Variables File
First, you must locate the variables.txt file on your system. Follow the steps below for your operating system.

Windows Vista/Windows 7/Windows 8
Click Start (Windows Key + Q in Windows 8)
Click Documents (Type documents and press Enter in Windows 8) and open the StarCraft II folder.
Open variables.txt.
Windows XP
Click Start.
Click My Documents and open the StarCraft II folder.
Open variables.txt.
Mac OS X
Open Finder.
Hold down the Option (Alt) key and select Library from the Go menu.
Navigate to ~/Library/Application Support/Blizzard/StarCraft II.
Open variables.txt.
This file contains the configuration for your StarCraft II client’s language and several other settings.

Change the Language Setting
In the variables.txt file, the following lines control your game client’s language:

localeidassets=enUS
localeiddata=enUS

Changing the information following the equals sign will change the language setting in-game. Be sure to save the file after any changes are made. Available languages are listed on the table below.

Note: Ensure that your language setting matches your game license’s language. If you have two game licenses on your Battle.net account, you will need to switch the language setting in this file each time you want to swap to a different license.

REGIONAL LANGUAGE NAME
The Americas
American English enUS
Latin American Spanish esMX
Brazilian Portuguese ptBR
Europe
German deDE
European English enGB
European Spanish esES
French frFR
Italian itIT
Polish plPL
Portuguese ptPT
Russian ruRU
Korea
Korean koKR
Taiwan
Traditional Chinese zhTW
Southeast Asia &
Australia/New Zealand
Southeast Asia English enSG
Reply Quote
Posts: 1
LIke always USA guys think just English exist on all planet.

It's completely idiot to need download 3.5 GB again to change language.
Bad programming.

People who know programming build all time option for language pack.
So you can change fast language of your software/games without to need to download all again.

But Blizzard don't care and think just to money.
Reply Quote
Posts: 12
So I changed my games text language to Korean, now I can't change it back to English. I go to Options again and try to change it, restart the game, but when it goes back on it's still Korean.

I checked the variables.txt and both localeidassets and localeiddata are enUS
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]