StarCraft® II

Gamma Issues

- Technical Support
i constantly get gamma going all bright with incorrect colors from time to time, i have to fix it by toggling graphics up then back down, it happens at random and it is annoying. it's a new issue, i'm not sure if it's related to my new 5870 or a recent patch. Just reporting issue here as i already know all the regular troubleshooting tips don't seem to work around it. it's not a cache or temp file bug, or bad OS or hardware. It's just either a bad 5870 driver bug, or something new in 1.1.3
Edited by Omega on 8/3/2013 5:51 PM PDT
Reply Quote
Support Forum Agent
Not the first I've heard of this, Omega. I'll get this to the Devs. Thanks!
________________________________________________
Account and Technical Services
Mac Specialist, Monday - Friday, 1:45pm-10:45pm Central Time
All knowledge is worth having, including how I'm doing. http://www.surveymk.com/s/T8L79P9
Reply Quote
- Technical Support
and to do this properly heh


Hardware Overview:

Model Name: Mac Pro
Model Identifier: MacPro3,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.8 GHz
Number Of Processors: 2
Total Number Of Cores: 8
L2 Cache (per processor): 12 MB
Memory: 10 GB
Bus Speed: 1.6 GHz
Boot ROM Version: MP31.006C.B05
SMC Version (system): 1.25f4
Hardware UUID: 854F34AA-C608-5128-A59A-C3C3921FF21D


ATI Radeon HD 5870:

Chipset Model: ATI Radeon HD 5870
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6898
Revision ID: 0x0000
ROM Revision: 113-C0780C-194
EFI Driver Version: 01.00.436
Displays:
Cinema:
Resolution: 1680 x 1050
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Display Connector:
Status: No Display Connected
Display Connector:
Status: No Display Connected


ATI5000Controller:

Version: 1.6.24
Last Modified: 7/17/10 3:06 AM
Get Info String: ATI5000Controller 1.6.24.17 (8901)
Kind: Intel
Architectures: i386, x86_64
64-Bit (Intel): Yes
Location: /System/Library/Extensions/ATI5000Controller.kext
Kext Version: 6.2.4
Load Address: 0xffffff7f812df000
Valid: Yes
Authentic: Yes
Dependencies: Satisfied



System Software Overview:

System Version: Mac OS X 10.6.5 (10H574)
Kernel Version: Darwin 10.5.0
Boot Volume: Mac OS X (SSD)
Boot Mode: Normal
Computer Name: Omega-3
Secure Virtual Memory: Not Enabled
64-bit Kernel and Extensions: Yes
Time since boot: 1 day23:05

Reply Quote
Support Forum Agent
As always, we appreciate it! I've already added this to my list for the week. :)

Wanna send me an ASP?
________________________________________________
Account and Technical Services
Mac Specialist, Monday - Friday, 1:45pm-10:45pm Central Time
All knowledge is worth having, including how I'm doing. http://www.surveymk.com/s/T8L79P9
Reply Quote
MVP - Technical Support
Bumping, because it's been over 2 years and it's not yet resolved and we have no information on any progress either.

http://mysticalos.com/images/gamma_brightness_bug/HoTS_bad.jpg
http://mysticalos.com/images/gamma_brightness_bug/HoTS_good.jpg

http://mysticalos.com/images/gamma_brightness_bug/WoL_bad.jpg
http://mysticalos.com/images/gamma_brightness_bug/WoL_good.jpg

WoL shots show the worst of it. it's hard to see in HoTS bad unless you know what it's supposed to look like (ie comparing it to good). It's more obvious it's wrong in evolusion chamber but i cannot toggle settings in there making it impossible for me to actually get screen shots of both good and bad in there. any time i fix it to look right by toggling settings up then back down or something, it doesn't stick for long, it goes back to crap second i switch from windowed to full screen, or full screen to windowed or any other kind of thing. It just really likes to go bad unless you play with lightning and shadows maxed out. the bug is definitely tied to these two setting "Lighting effects" and Those special campaign only shadows forget what they are called. It seems the issue happens a lot less if both of those are maxed out. It's very hard to get the gamma not to be screwed up with the super shadows turned off and lighting set to only medium or high.

Software:

System Software Overview:

System Version: OS X 10.8.4 (12E27)
Kernel Version: Darwin 12.4.0
Time since boot: 7 days 21:27

Hardware:

Hardware Overview:

Model Name: Mac Pro
Model Identifier: MacPro3,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.8 GHz
Number of Processors: 2
Total Number of Cores: 8
L2 Cache (per Processor): 12 MB
Memory: 10 GB
Bus Speed: 1.6 GHz
Boot ROM Version: MP31.006C.B05
SMC Version (system): 1.25f4

Graphics/Displays:

AMD Radeon HD 7950:

Chipset Model: AMD Radeon HD 7950
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 3072 MB
Vendor: ATI (0x1002)
Device ID: 0x679a
Revision ID: 0x0000
ROM Revision: 113-E2080C-101
EFI Driver Version: 01.00.624
Displays:
Cinema:
Display Type: LCD
Resolution: 1680 x 1050
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: 2A70928FUFZ
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported

Other:

Input Source ID: com.apple.keylayout.US
Keyboard Layout: ANSI
Edited by Omega on 4/14/2013 2:10 PM PDT
Reply Quote
MVP - Technical Support
other noteworthy threads over the years have been up, hard to find them though with search so i only found this one.

http://us.battle.net/sc2/en/search?q=gamma&f=post&forum=119207

Others existed but probably under more obscure names that make search terms fail, leaving them buried in the past now.
Reply Quote
MVP - Technical Support
Also to mention, does not happen anywhere else but campaign. missions do not display this behavior.
Reply Quote
MVP - Technical Support
still persists in 2.0.10, I can pretty much only get it go away if i run settings way beyond my spec, since the gamma issues only happen on low/medium settings most of time. I haven't been able to complete campaign because i can't stand to look at it like this. :\
Reply Quote
I'm able to reliably get SC2 gamma to be incorrect by going into/out of windowed mode while the map-loading screen is in progress.

I notice this when laddering 1v1. I have my settings on low, but can provide my exact configuration details if that's helpful.

I'm able to get SC2 to "reset" it's notion of gamma, by going to the video settings and adjusting the gamma. As soon as I touch the gamma slider, the gamma will "jump" back to a reasonable value.

My understanding of the bug is that the sc2 gamma adjustment is disabled when going from fullscreen to windowed mode (which makes sense, otherwise the rest of the OS would look odd). But then if I return to fullscren mode while sc2 is otherwise busy (like loading the map) it fails to remember that it's supposed to re-adjust the gamma.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]