"Must Upgrade to access content"


Posts: 2
Worked this morning but not now,
Posts: 46
Same here for my wife and me.
Posts: 15
Can we get an update from a blue please!????????? We are kind of in the dark on this atm
Posts: 6,152
It was working for me about an hour or two ago but my games was lagging bad. I had to quit. Then it failed to start my next game (telling me I lost immediately after connecting or something).

So I took a break. I come back and I've got the lock on my Play button.

(Hey, maybe they're patching the worker /mineral patch / fog of war exploit :) )
Edited by Demiwraith on 5/30/2014 10:31 PM PDT
Posts: 1
Posts: 1,322
Rekt like me I see...

Posts: 4
Bump. I need my ladder!!
Posts: 69

Posts: 1
and bump.

why are there no replies here?
Posts: 8
Bump. Same for me, and I have full game and expansion and played just two days ago.
Posts: 2
Same issue! :(
Posts: 3

Worked for me yesterday - but failed after a small auto update this morning.

Also there is another thread with the same issue under a different title - "Starcraft 2 lock on play in matchmaking".
Posts: 8
Posts: 1
Posts: 2
Posts: 6
Posts: 6
same issue!!!!!!!
Posts: 14
Me too.
Posts: 14
I am ready to upgrade!!!
Posts: 11
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)