StarCraft® II

Please help Blizz. Error installing SC2

Today my SC2 failed to run and the repair tool needed to be run, after attempting to repair starcraft twice it recommended a re-install.

I reinstalled in safe mode with networking and got this error while patching in regular windows.

The patch "pc-battlenet-hdfiles\Support\Battle.net.dll" could not be applied.The patch "pc-battlenet-hdfiles\Support\Battle.net.dll" could not be applied. (MD5 mismatch: expected 0xC7EEFE5D057E19C447DEF228C1F4F229, actual 0x76CFE96286B65BEE36D6E1748625DE11.)(PTCApply_BSDiff failed.) If this problem persists, you may be able to solve it by uninstalling and then reinstalling the game. If you are unable to correct this problem, please contact Blizzard Technical Support. (BNUpdate::PTCApply)

FYI... I've had to uninstall and reinstall this game over 15-20 times... I don't know why but this game does not agree with my system..

Please help. I can't take anymore problems

My computer more than exceeds maximum settings hardware requirements. I'm running windows 7 64bit.
Reply Quote
Tried uninstalling and re-installing a couple more times... same issue, new error.

The patch "S2.Win.16389\base\Campaigns\LibertyStory.SC2Campaign\Base.SC2Data\TriggerLibs\CampaignLib.SC2Lib" could not be applied. (MD5 mismatch: expected 0xCE95622818981C9E8027AAE207C46506, actual 0xD70E60FAF0617A53AC48D242C28F7F3F.)(PTCApply_BSDiff failed.) If this problem persists, you may be able to solve it by uninstalling and then reinstalling the game. If you are unable to correct this problem, please contact Blizzard Technical Support. (BNUpdate::PTCApply)

This is ridiculous.
Reply Quote
It's definitely a Starcraft II problem. The problem probably won't change much, no matter the amount of reinstalls, because when you uninstall something it doesn't "really" uninstall everything.

Use Revo Uninstaller to remove all remnants/registry keys/etc., then use CCleaner and Defraggler to clean up your computer to remove any other corrupted .dll left over.
http://download.cnet.com/Revo-Uninstaller/3000-2096_4-10687648.html
http://www.piriform.com/ccleaner
http://www.piriform.com/defraggler

Then try reinstalling the game via this:
http://us.blizzard.com/support/article.xml?locale=en_US&articleId=26257

Now, when applying the patch, it looks like something is going horribly wrong. And I've seen this lots of times before, so you're not the only one, but I've forgotten the specific steps on resolving it (since I've been gone for a while.) Here is the standalone patch until I brush up on this issue, or a representative/community member can answer:
http://us.blizzard.com/support/article.xml?locale=en_US&articleId=35087
Reply Quote
Thanks for your help Aragorn.... However despite attempting your suggestions 3 times today, I'm still encountering the same problem while patching.

I seemed to get pretty far in patching... maybe failed on the 6th or 7th of 7 patches... new error.

The patch "pc-game-hdfiles\Versions\Base15405\SC2.exe" could not be applied. (MD5 mismatch: expected 0x514CA3154F8F40F242E6B194766CCAED, actual 0x0E038AC606B9910E402C8E737CF6A996.)(PTCApply_BSDiff failed.) If this problem persists, you may be able to solve it by uninstalling and then reinstalling the game. If you are unable to correct this problem, please contact Blizzard Technical Support. (BNUpdate::PTCApply)

I'd love for a Blizzard rep to thrown in their two cents and help me out however I suspect they will continue to ignore me as always.. Take my money and run Blizzard... take my money and run.
Reply Quote
After Re-installing the game another 6 or 7 times i finally got a good install and patch...

Thanks for trying to help Aragorn, I really appreciate it.

As for Blizzard thanks for ignoring me as always... I look forward to the near future when Starcraft again corrupts itself and will not properly re-install, and once again you can ignore me and be as unhelpful as possible.
Reply Quote
Looks like my crashing.. into.. repairing.. into re-installing cycle is starting again.... feel like ignoring me some more Blizzard?

First time it crashed... it told me my install was corrupt and I had to re-install. I restarted SC2 anyways and the game ran fine for a few games.. then crashed again... I tried to repair again... and then the repair tool completed fine and it said there was no issues..

What gives with that.. how is the installation so corrupt one minute that I have to re-install... and then the next minute no issues were found.

Reply Quote
Could be memory related. Other than that, I don't know.

You can either use Memtest86+, Prime95, or manually remove and test individual sticks to identify hardware problems.

Memtest86+ [need CD or DVD]
http://www.memtest.org/
http://www.geekstogo.com/forum/topic/246994-guide-to-using-memtest86/

Prime95 (32-bit)
http://files.extremeoverclocking.com/file.php?f=103
http://www.playtool.com/pages/prime95/prime95.html

Manually
Shutdown computer > unplug power cable from back > leave alone for 10-20 minutes to reduce static > ground yourself > open side of case > remove all sticks but one > reboot and play.

If it works. That stick is good. Remove that stick and put another in it's place, and so on, until you find the bad stick or bad slot.
Reply Quote
I have tested my ram using a method such as your "Manually" section and found no problems... I did suspect hardware issues myself prior to realizing that none of my other games crash.... not even once.

That leads me to suspect that it is actually starcraft itself.. but since Tech Support ignores me.. might as well test my ram again.
Reply Quote
Yeah. I'm not sure what can be done. This has been a problem for months now.
http://forums.wowlite.net/sc2/thread.php?id=628079843&forumID=13438&region=us
Reply Quote
Support Forum Agent
It sounds like your system is causing the data to corrupt repeatedly, although some of the errors are typically the result of system restores. Do you know when your last system restore was? Some systems will automatically do a restore if they detect a problem.

If your system is not doing system restores, then thiis is typically caused by either faulty hardware or other forms of system instability, and your instinct to suspect the RAM was a good one since that is the most common cause for these issues.

If your system is over-clocked or under-clocked, try setting it to the recommended values.

If that is not the case, then we will want to check your hard-drives and RAM for issues.

Try running a checkdisk on your hard-drive and see if that corrects this. It is a long-shot, as your errors appear to be happening on a number of different files which is not typically an issue with the hard-drive unless you are in the midst of hard-drive death. Despite that, it is a simple-enough thing to determine.

Checkdisk Instructions: http://us.blizzard.com/support/article.xml?articleId=21237

If it still occurs after that, I would suggest that you check your RAM again to make sure that it is not faulty.

Here's how to test the RAM:

The most reliable way to check your RAM is to physically remove all but one stick of RAM and then try with only that stick. If you still get errors, swap that stick for another and test again.

If you are not comfortable or are unable to do that, you can run a program to diagnose the RAM, although it is less reliable.
1. Click on this link and download this memtest tool: http://hcidesign.com/memtest/download.html
2. Once the tool is download you will need to extract the zip file onto the desktop
3. Once extracted you should have a memtest icon on the desktop with a green check mark on it. Go ahead and double click on this and follow the on-screen instructions.

*Note* If you have a lot of RAM installed then you will want to run multiple memtest tools at the same time. I recommend to test 1gb per memtest. So if you have 2gb of RAM you will run 2 memtest with each one testing 1gb.
________________________________________________
Account and Technical Services || I am available Tues-Sat 6:45AM-3:45PM Pacific
Can't find a resolution on the forums, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
https://www.surveymk.com/s/RZRWLCB ---- Show me you love me!
Energy saved from one recycled aluminum can will operate a TV set for 3 hours, and is the equivalent to half a can of gasoline
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]