I can't load my saved campaign games

Posts: 4
I see them in my directory in my 'starcraft 2' folder but when i boot up the game it says i have 0 achievements and it says 'start new campaign' or 'load' and when i press 'load' there is nothing there even though i just beat (and saved) the outbreak mission last night.



i tried just opening the saved files from the directory with the starcraft 2 launcher but that doesn't work--just boots the game up normally and then i run into the same problems. is anyone else having this issue? i guess i could just leave the game on until i beat campaign but i imagine i will run into similar annoying issues when i move onto challenges and online multiplayer play.



i also inexplicably lost my connection to bnet in the middle of playing campaign--im not sure if that's a contributing factor, but either way i have all my saves on my hard drive so i can't imagine there isnt some kind of resolution here
Reply Quote
Posts: 4
really? i'm the only one with this problem?
Reply Quote
Posts: 3
Ya im having this same problem. This is unplayble like this.

Blizzard?
Reply Quote
Posts: 30
I have the same problem. I think it has to do with my crappy internet connection. I get frequent disconnects here in Canada with Rogers (seems to be a known issue with them). When I get disconnected (even for a second) I lose my Battle.net connection and anything "Saved" doesn't actually save and no achievements can be won, etc... Definitely a *huge* annoyance for me. Seems I can't play single-player because I get high latency causing frequent disconnects causing unsaveable game state. :-(
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]