StarCraft® II

NVIDIA users with Cinematic Issues

Simply update your video drivers and your cinematic problems should be over with. I haven't adjusted my setting on my video card or SC2 and I updated my drivers and it instantly fixed my issue. I do have a GeForce GTX 260M. If you have any questions ill see if i can help...
Reply Quote
What driver version is it?
Reply Quote
I have the latest and greatest from Nvidia but had to disable SLI to get the cinematics to run flawlessly. Like World of Warcraft this game also doesn't seem to like SLI. I have 2 Nvidia 275GTX's.

Reply Quote
Another solution to avoid having to disable SLI, turn Lighting down to Medium... Fixed it for me. I just hope whatever the problem is, they address it soon.

I am also using the latest drivers from nvidia... Using 2x GeForce 9800 GTX+ 512mb's.
Edited by MoleZ on 7/28/2010 2:53 PM PDT
Reply Quote
Minus, I downloaded the Geforce 200m Series(notebook) Driver for a 64bit processor, here is the driver version :258.96 WHQL. To get recent updated drivers from NVIDIA, goto http://www.nvidia.com/Download/index.aspx?lang=en-us Let me know if that helped.
Edited by SKTpyro on 7/28/2010 3:33 PM PDT
Reply Quote
Using the latest drivers doesn't fix the issue for me either. Does seem to be an issue with SLI. Blizz is aware and have posted elsewhere that they're looking into it.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]