StarCraft® II

Weirdest fix for fps lag but it works

Posts: 36
First of all, you have to ask yourself if you are suffering from the same kind of FPS lag. Here were my symptoms:

1. Games began at or near max FPS (30+)
2. After a while, the game will stutter down to wretched FPS (5, etc)
3. Turning the graphics from ultra to low doesn't make a difference

Number 3 is the biggest thing here. If you notice that changing all your graphics from ultra down to low makes no impact on the game's performance, something is up. What I tried at first was "stressing" the GPU/CPU into taking larger loads. I'd begin a custom game with 8 people and turn up all settings to ultra. Then I'd open another game and it'd be smooth all through.

The solution is that some nvidia cards (and perhaps amd, but I'm using an nvidia laptop) uses a "power-saving" mode. I've even heard of people who have super good computers with amazing GPUs have this problem because their card goes into its special, low-clock power save mode and doesn't recognize that SC2 requires a lot more speed to get it going. Here is how to fix the problem (first you should get the latest drivers so we're looking at the same panel):

1. Right click on desktop
2. Open nvidia control panel
3. Under 3D Settings on the left panel, select "Manage 3D Settings"
4. Scroll to "Power Management Mode" and, to its right, change the selection to "Prefer Maximum Performance"

I don't know if this will work for you but it worked for me and I haven't seen this fix on the forums or online so here it is =D
Reply Quote
Posts: 381
FYI this should only work while the laptop is plugged in and may fail anyway if your laptop starts to get too hot.
Reply Quote
Posts: 36
01/31/2011 9:40 AMPosted by Simian
FYI this should only work while the laptop is plugged in and may fail anyway if your laptop starts to get too hot.


Thanks for the input. I don't know anyone who plays SC2 while on a non plugged in laptop. It drives the battery life right into the ground (all those fake estimates of 7+ hrs go right down to around 1 hr or less with 3D gaming).

But so far, it's been working fine. In fact, the more the fan runs (the hotter the computer runs) the better the FPS seems to work. And on a desktop (I assume most SC2 people are desktop users), you should have no problem with using the "Prefer Maximum" setting.

Hope this works for anyone with the same kind of FPS lag as me. =D
Reply Quote
Posts: 2,216
Yeah. It's apart of the throttling mechanism. Make sure to set high performance settings in general to avoid CPU throttling as well.
Reply Quote
Posts: 36
Actually, this doesn't work all the time. Can someone give me a better solution?
Reply Quote
Posts: 1
My power management only allows and "adaptive" selection. Is there anything else i can do? I have the NVIDIA geforce 6800
Reply Quote
Posts: 4
If you're using Windows 7 (and maybe Vista, but I can't remember), this is how I fixed the problem:

Start
Control Panel
Power Options
Disable "Power Saver" mode. There was an option for High Performance mode, which is what I switched it to.
Reply Quote
Posts: 306
Going to +1 what Rion and OP said. Both what the original poster and what Rion said have both helped me dramatically in the past. I have a nvidia 485.
Reply Quote
Posts: 1
For those with High End Nvidia GPU's

Worked for me!

Download this:
http://www.nvgpupro.com/

Disable Powermizer settings. It slows down your card to manage heat.

NOTE: I also suggest installing something like EVGA PrecisionX to monitor your temps manually. If you do experience some heat issues, you can always crank up the fan speed in said application. Do not use it for overclocking your card unless you know what you are doing. It may cause damage.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]