StarCraft® II

Mac (command + function keys) hotkey bindings

(Locked)

I play Starcraft 2 on a macbook pro and I was trying to set my camera location hotkeys when I ran into a problem. The command card doesn't recognize when I press command + any f-key. I have already disabled my f1 shortcuts in system preferences so they act as normal function keys, and I disabled mac shortcuts in battlenet settings.

It still recognizes the f-keys as normal. For example, I can set "jump to location 1" as f1, but I can't set "create location 1" as command + f1.

For some reason, it still recognizes option + f1.

It already has command + f5 set as "create location 1" but as soon as I overwrite it, I am unable to go back to it.

Any ideas on how to fix this?
I believe I’ve seen a thread about this issue before, and I don’t think anyone posted a workaround. I suggest posting about this in the Bug Reports forum.
I'm experiencing the same problem. My workaround was to try to change the hotkeys for locations, like command+f7, ect. Unfortunately, what's worse is that if I try to change my hotkeys such that command+m assigns a location (as opposed to command+f7), I can't actually assign "command+m"...it will only recognize "command". I hope that makes sense. Basically, we're A) having trouble defining a hotkey composed of a combination like 'command+m', for example and B) having trouble using the f keys during gameplay. We're heavily handicapped by this...kind of makes the game not fun to play. It's annoying not being able to jump around the map like I'm used to from the original game.
I'm having the same issue with a few key combinations, and I think it's because they're non-overrideable OS-level shortcuts. For example, command+v is paste, command+m is minimize/maximize, command+h is hide, command+q is quit, etc. Even the SC2 "Override OS Keyboard Shortcuts" option doesn't disable these and it's very frustrating.
I have the same problem with my MacBook, the f keys will not work when i select them to macro. very frustrating.
Support Forum Agent
Hey all,

Thanks for reporting these. I do know that certain hotkeys cannot be bound, like Cmd and Q,M, and etc, but the function keys I do not know about. I will inquire about these and see what's up with them.

Do you have standard Apple keyboards? And if so, are these full sized keyboards or the Wireless/Laptop keyboards where you have to us the 'fn' key to toggle this.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. How's this sheep doing?
Dedciated to making your Mac/Blizzard Experience an awesome one!
Tauren (eating a hamburger): Hamburgers are made of what??!!!!!
This is happening to me as well. This only happens when I'm using the standard size wired Apple keyboard. If I hook up a non-apple keyboard the F keys work.
Support Forum Agent
Hi Tribe,

Thanks for the additional report.

Just to make sure I understand, trying to hotkey any of the F-keys like F1 with the Command Key does not work on an Apple Keyboard (fullsized with 10-key I assume since you stated wireless), but works on a non-Apple Keyboard is that correct?

Can you verify if this is with a fullsized Apple Keyboard w/the 10 key? Some of the Apple Keyboards have the "fn" (function" key) which you would need to toggle in the system preferences to amke it work properly.

This will help me in our research, thanks!
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. How's this sheep doing?
Dedicated to making your Mac/Blizzard Experience an awesome one!
Knowing others is intelligence; knowing yourself is true wisdom.-- Lao Tzu
Edited by TonyM on 11/11/2011 1:22 PM PST
go to options, go to controls and then disable os keyboard shortcuts, this worked for me.
Edited by LzyPterosaur on 12/5/2011 2:58 PM PST
12/05/2011 02:52 PMPosted by LzyPterosaur
go to options, go to controls and then disable os keyboard shortcuts, this worked for me.

hi, I tried checking that option to disable to OSX commands before, yet it was not working for me, unfortunately.

What I intend to do is to have an uniform set of keybinds on my OSX Lion and Win7 bootcamp, so that I can have a more streamlined experience. That is, wherever I log in, SC2 intelligently applies my custom keybinds for me, but if I were to have to make another set of keybinds specifically for OSX, it would be fairly annoying to have to switch between them whenever I log on under a different operating system.

The specific key binds that do not work are the camera location ones. For instance, I rebound ctrl F2~F8 to recall camera locations. This works great on Win7 bootcamp, but it just would not work under OSX for some reason.

Btw, I am running on a late 2011 15" MBP with OSX Lion.
Edited by DaciMVRL on 12/5/2011 4:51 PM PST
Support Forum Agent
After doing a few test, I was able to successfully bind Command + [Any function keys] and Control + [Any function keys].

Like others have mentioned, make sure you have "Use all F1, F2, etc keys as standard function keys" check under System Preferences => Keyboards and "Disable OS keyboard shortcuts" in StarCraft II. This should allow you to bind Control keys to function keys.

I was also able to bind the Command + function keys. You will need to ensure you have "Enabled access for assisted devices" checked under System Preferences => Universal access.

These were done using the Apple keyboard (wired USB). I would recommend trying this out. Let me know if you have issues still and please put down what kind of keyboard you have.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Sunday to Thursday 11:00 am - 8:00 pm CST
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. How's this sheep doing?
The mechanical sheep with a heart of gold...
If at first you don't succeed... call it Version 1.0..
Edited by TonyM on 12/6/2011 6:11 AM PST
I was not on a wireless keyboard, thank you for the response.

Actually what was happening was that my "saved" settings were not in play, so my camera hotkeys were not bound because they were on the "standard" layout and not my custom layout.

- go figure.

Thanks for looking into it however. It did make me bear down and try and actually find the problem.

P.S. - What really sealed it for me is that while using a mac, I changed to a SteelSeries G6v2 and found that I was having the same problem. That is when I noticed that my hot keys were no longer bound.

So i have a Mac Book Pro OS x 10.7.2 and I have done everything suggested on the thread for the Function keys and it still doesn't work.
Support Forum Agent
Hi Atreides,

Can you tell me which items you've tried? Also, let ,me know which specific keybinds you are having issues with.

And can you post some system specs, so we can know what we are working with?

Obtaining System Information
    1. Hold the "Option" Key and choose "System Profiler/Information" from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)

________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment
Not finding what you need here? Contact a rep direct! http://us.battle.net/support/en/article/contact
The Mechanical sheep formerly known as as TonyM!
So, Thrall, Jaina, and Kerrigan are all sitting around playing poker…
I have a macbook pro and my "f" keys don't work either. For example "f1" will NOT select idle workers. I'm using the stock build in keyboard.
Support Forum Agent

Like others have mentioned, make sure you have "Use all F1, F2, etc keys as standard function keys" check under System Preferences => Keyboards and "Disable OS keyboard shortcuts" in StarCraft II. This should allow you to bind Control keys to function keys.

I was also able to bind the Command + function keys. You will need to ensure you have "Enabled access for assisted devices" checked under System Preferences => Universal access.


This should make f keys be able to be bound and be hotkeyed to the modifiers Control/Command.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment
Not finding what you need here? Contact a rep direct! http://us.battle.net/support/en/article/contact

So, Thrall, Jaina, and Kerrigan are all sitting around playing poker…
Sorry I have tried "Use all F1, F2, etc keys as standard function keys" check under System Preferences => Keyboards and "Disable OS keyboard shortcuts" in StarCraft II. This should allow you to bind Control keys to function keys."

Still doesn't work completely.

What is interesting is that F1 is recognized for idle worker and F9, F10 work fine to bring up menus. have Apple external USB keyboard. And I dont have to touch the fn key to get the function keys to respond.

But Shift +F2 and F2 dont do anything. I dont understand why locations cannot be bound.

Thanks.
My bad. I thought the keys were F1-F4. F5 -F8 seem to work fine.
i can't use my camera hot keys either, worked before latest patch
Support Forum Agent
This sounds like a different issue. Can you create a new post with what is going on? This is an old post from July 2012.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]