1080i instead of 1080p???

Posts: 3
Hello,

I'm running an early 2011 15" 2.3GHz MBP with 6750M running OSX 10.6.7

I'm using a minidisplayport to HDMI cable

Its connected to a Dell S2409W monitor

The problem (like the OP) is that when i set the display to 1920x1080 in the game video options, it outputs 1080i instead of 1080p and so my display goes nuts flickering, overscanning, and looking like crap.

This hardware setup works perfectly in SCII in windows and for all other purposes on Mac. Its just this particular game in Mac.

Please help!
Reply Quote
- Technical Support
Posts: 10,188
i believe this is an issue in wow too and has been mentioned in great detial by a forum regular over there named tiap. I don't know where thread is off top of my head but i'm sure Tony can come in herewith info about it as i'm quite sure tiap has grilled him on it time and time again ;)
Reply Quote
Posts: 5
Hello,

i've got the same issue.
I've got a Mac Mini 2011, 2.5 GHz Intel Core i5, 16 GB Ram & AMD Radeon HD 6630M 256 MB and 2 Dell S2240L displays one through the HDMI port and the other one via an Mini DisplayPort to HDMI adapter. The main monitor is the one from the Mini DisplayPort.

My default refresh rate (for OS) is 60Hz NTSC and it's set to 1080p. if i change it to 1080i the image will be overscaned and will flicker. This is exactly what happens when i run the game also. The image is overcaned and flickery.

The same thing happens with both monitors, regardless which port i use (so it's not the displayPort) and happens in fullscreen and windowed fullscreen.

It's very frustrating because i get a terrible headache after playing more than an hour... it's disappointing... This is a major bug...
Edited by Cubed on 4/6/2013 2:01 AM PDT
Reply Quote
Posts: 5
This seems to solve the problem but only if you press cmt+Tab and switch to game again after starting the game.

WoW have a known bug regarding 1080p on the Mac client. If you have WoW set to use the 1920x1080 resolution and it changes to 1920x1080i, then you will need to download and install SwitchResX, located here:

http://www.madrau.com/download/latest/latest.html

After installing SwitchResX, you will need to go to the tab with your TV's name in it and click on the Current Resolutions tab. In there you'll see a long list of resolutions. You are interested only in two. The first is 1920x1080@60 Hz. There will be two entries for this. The first is going to be the interlaced resolution. You'll want to redirect it to the second. You'll see where in this screenshot:

http://img807.imageshack.us/img807/1647/screenshot20120303at332.jpg

My list shows "1080i (NTSC)" and "1080p60 (NTSC)". I renamed them slightly from their original form to denote the interlaced and progressive scan forms of 1920x1080. To rename these you need to click on the name in the leftmost column and type in the new name. To redirect the first 1080 to the second 1080, click the word "Enabled" in the Active column and select the second 1080 entry from the list. It will look like so in that list (remember the highlighted one will be the last entry on the list usually):

http://img525.imageshack.us/img525/5324/screenshot20120303at341.jpg

This will make WoW redirect from 1080i to 1080p, effectively disabling 1080i in most circumstances, allowing you to have a clear, crisp gameplay experience.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]