StarCraft® II

Pylon aura lag. What graphics setting to use?

Posts: 7
As the number of pylon auras on my screen increases, my FPS goes down.

My question is simple - what graphics setting do I need to lower?

My system: Windows 7 Professional 64 bit, Asus P5Q Pro, E8400 dual core Intel processor, an Asus 512MB Radeon 4870 with 10.7a hotfixed drivers (had the issue before on 10.6 as well), and 4GB OCZ DDR2 RAM.

Thanks in advance for any help!
Reply Quote
Posts: 541
same happens to me lol, if they're really close to each other
Reply Quote
Posts: 24
I'm having the exact same issue, one pylon is OK, two pylons overlapping still OK, but after that, they just add major lag each time you try to build something near the pylons, or when you try to build another pylon while seeing the 'build' area of a pylon.
Reply Quote
Support Forum Agent
Posts: 5,037
Devs are currently looking into this issue but try setting your model quality to low. That should affect pylon grids too.
Reply Quote
Posts: 7
Thanks for the quick reply datth!
Reply Quote
Posts: 2
It seems to happen only on some maps. I believe it depends on the terrain you're playing on. Usually maps with grass bogs down your computer whereas maps with sand don't lag at all even with 6-8 pylon auras active.

I tried running everything on the lowest graphics quality except for Models which was set to high. Even then, on maps with grass I still experience lag. I'm currently running on 4GB of RAM and 1GB of dedicated video RAM so experiencing lag on the lowest graphics quality should be near impossible.
Edited by DeusEx on 8/4/2010 12:44 PM PDT
Reply Quote
Posts: 22
yep, im experiencing this, i get a 50 fps drop when there are like 4 pylons on screen. Its messed up cuz i can play the game high settings native resolution 1680x1050 60 fps...I never got this in beta btw.
Reply Quote
Posts: 7
I actually prefer the way Pylon auras are displayed when you set model quality to low.
It still lowers my FPS when I have multiple Pylons, but not as much as it did before. It's obviously just a bug or technical issue that will be patched/fixed soon.

I'm still quite happy to have every other graphic settings maxed out - model quality didn't seem to effect anything except the Pylon auras.
Reply Quote
Posts: 7
Same here.

Windows 7 x64

Pentium(R) Dual-Core CPU E5400 @ 2.70GHz 2.70 GHz
(RAM) 6.00 GB
NVIDIA GeForce 9500 GT
Driver Version 8.17.11.9745
Reply Quote
Posts: 18
Heh yeah me too. Here's my computer's specs...

Windows 7 Ultimate 64bit
Intel Core I-7 @ 2.93ghz
8GB DDR3 Corsair
Nvidia Geforce GTX 295 with driver version 8.17.12.5896

Nothing on my system is overclocked. Everything running smoothly on lowest graphics settings one can possibly go (besides models) until I build like 15 pylons in my base and click on one. With what normally would be 150ish fps I get a 130 fps decrease. C'mon now we can fix this ridiculous issue lol!
Edited by Ortou on 8/8/2010 12:58 AM PDT
Reply Quote
Posts: 221
Disable AA (Anti Aliasing) and AAA (Adaptive Anti-Aliasing) The game looks sexy enough without them.
Reply Quote
Posts: 21
I have this issue as well, and no, overclocking is obviously not the problem.

ASUS G51VX-D1-BIL Notebook
Windows 7 Home Premium 32-bit
Core 2 Duo T6600 @ 2.4 GHz
1 GB GeForce GTX 260M @ 280M clocks using ForceWare 258.96
4 GB DDR2 800 Dual Channel RAM @ 860 MHz
Reply Quote
Posts: 26
I have the same problem, an the only thing that helps is lowering the shaders to medium or low...

I can have everything else on ultra with the shaders on low with now problem.. but it's not kool.

My laptop is Studio XPS 1647
i7 630 @ 2.7ghz, max 3.3ghz
ATI 4670 1gb
4gb DDR3 ram
w7 home premium 64bits


Reply Quote
Posts: 34
I'm getting the same thing, both with pylons AND when planting creep tumors (that green swirly circle thing, which I don't remember seeing a while back). It sucks because that's the only time I have any serious lag when playing with the settings I have.
What other graphic elements does lowering the model quality affect?
Will there be any adjustments to this in the future? Perhaps a separate setting specifically for pylons and creep tumors would help.
Reply Quote
Posts: 1
I ran into that too...

My specs are..

Windows 7 Pro 64-bit (Build 7601) SP1
C2Q8400 @ 2.66GHz
Asus P5PQ (standard)
6GB DDR2 @ 800Mhz
GIGABYTE GTX 460 1GB OC'd @ 875/1750/2210 with Driver's version 267.24

I've set everything to low (even the detail quality) and it still lagged. Hmm. I even ran Game Booster and it doesn't do much of a deal... What a ridicule issue... Well, can't really play Protoss for a while so I might just stick with the Terrains and Zergs for the change.
Reply Quote
Posts: 178
If you have an Nvidia card, try the latest drivers - they were released just a few days ago. That might help the issue you are seeing.
Reply Quote
Posts: 38
just got a new AMD laptop, midrange specs (a6 1.6GHz quad core CPU OC'd to 2.6) and dual GPU graphics.


game runs perfectly smooth (and stable, dont even think of mentioning the OC as the cause of problems) until i place pylons. 60FPS down to 20.


can we please get a toggle option for low quality pylon/creep tumour rings, independent of other graphical settings? we only need a simple ring like range on cannons.
Reply Quote
Posts: 7
Any update on the pylon lag issue ? Seems ridiculous that everything runs on high model without any lag except Pylons in a close proximity of one another.
Reply Quote
Posts: 241
Most players haven't had issues with this in a while, you should at least post your pc specs if you are still having a problem with it.
Edited by StarPlayer on 5/6/2012 8:31 AM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]