StarCraft® II

The END to all stuttering/low FPS problems?

Posts: 12
I just discovered a very interesting "solution" after hours/days/weeks/months of continuously trying to solve SC2's seemingly random FPS stuttering:

Alt-tab to another program


Ok, obviously not the most ideal solution, but I think (hope) that this will lead to new ground in fixing this problem. Hear me out!

My specs (core applicable hardware):

    i7 930 @ 4.2Ghz
    12GB DDR3 1600
    Intel G2 120GB SSD
    XFX 5850 1GB @ 960Mhz/1300Mhz (ATI card)
    3x Dell 2408WFP LCD Monitors, each natively 1920x1200


I run all SC2 at 1920x1200 Ultra; everything maxed except for the bottom right "Extreme Shading" option, which is off (can't remember exact name). The game typically runs buttery smooth, except for moments of stuttering. This stuttering happens at occasional moments in cinematics, and often during pre-mission character talk, like when the Adjutant is scrolling view across the map while giving details.


I have tried every possible combination of --

    -trying and installing every possible set of ATI drivers over the past year (doing a extremely thorough removal of each set)
    -trying with and without Catalyst Control Center running, along with testing each setting variable individually (and Catalyst AI both on and off)
    -Framerate caps and glues in variables.txt, Vsync on/off
    -Forcing Direct3D triple buffering and vsync
    -Killing all other running applications
    -Lowering resolution and graphics a couple notches (no difference in the random stuttering)


A couple things have vastly improved gameplay with drastically less stuttering:

    -Disabling that Extreme Shading option
    -Running the game in "Windowed (Fullscreen)" gave MASSIVE improvement. With that, while in the SP Cantina, I could now click on any of the trophies/placards in the top right of the screen and have the camera zoom in with perfect fluid motion, no minor hiccups
    -In variables.txt, changing Transparent Shadows to 0 (I thought this worked, further testing proves inconclusive)


Specifically, I have always gotten the worst choppy/stuttering in the cinematic where Tychus and Raynor storm the Prince's battlecruiser, solely and right at the moment where Raynor explodes through the door. This always gives massive choppiness, even when the camera backs up and we see him charging toward the prince. As soon as he pulls his gun out, the choppiness always goes away.

I changed TransShadows to 0, disconnected my other two monitors (thinking maybe they were drinking up the 1GB gpu memory), shutdown everything, and then watched the cinematic. Amazingly, Raynor blew through the door buttery smooth! I thought I had it.

After watching the cinematic again, however, the choppiness was back. Arghh






Ok, now the discovery I've made --

I've been pondering why Windowed Fullscreen runs much smoother than Fullscreen, as it seems counter-intuitive that the GPU would handle it better when it's basically sharing GPU processing with other windows and Desktop Manager (I should go google why, as I've heard it usually is the other way around...).

While I was watching the cinematic yet again, I tabbed out to open Windows Services manager, to make sure an Intel Rapid Storage service wasn't restarting itself up and possibly choking up the hard disk transfers. Because I was running the game in Window Fullscreen, Window-key opening the start button menu wouldn't downsize the game, but rather keep it playing behind whatever other windows I had.

As the cinematic was nearing the exploding door part, I alt-tabbed to the Services window and watched to see if the service happened to be starting. To my absolute surprise, Raynor blew through the door smoother and silkier than EVER before. I quickly tabbed back into SC2 and Raynor instantly started the slight micro-stuttering/choppyness. Thinking it was just because the game had to "reload" GPU data now that it was the focused window, I waited a sec -- still slight micro-stutters (not extremely noticeable, but almost like random frames are getting cut, giving little hiccups or jumps).

I rewatched the cinematic, again alt-tabbing out and in. Without fail, if another window has focus with SC2 playing in the background, the cinematic is completely SMOOTH without a single hiccup to be seen.

Any ideas why this would be? And how could this be evolved into a remedy? Why would SC2 get choppy and stutter when it has the focus? Why would it run better than ever before when it's running in the background, which IMO seems contrary to logic, thinking the GPU would downgrade its priority?

Some hypotheses I have:

    -Something to do with the CPU. Perhaps when a thread is not the active focus, Windows divides the processing cores differently, somehow (unintentionally) giving SC2 the exact CPU processing it was designed for (SC2 apparently doesn't like lots of cores). I've tried before of changing SC2's processor affinity to only core core, and then two cores -- no difference.

    -Perhaps it has something to do with the sound processing or drivers. When not in focus, the sound stops playing. Could that mean that the sound processing drivers are clashing and inhibiting the graphics processing portion? I think I'll try removing all sound devices and drivers to see if SC2 plays buttery smooth while in focus.



Would anyone who has this problem and reads this please test method out? I realize this probably isn't the end-all be-all of FPS solutions, but I wonder if this could help a lot of people. It's simple to test -- run the game in Window Fullscreen and when you approach a part that typically stutters/chops, press the Window Key to take away focus (or alt-tab to another window, making sure you can still see most of the SC2 window running in the background).
Reply Quote
Posts: 1
I just bought the game today. My PC isnt the best but at the very least it should be able to run the game fine on the lowest settings. However, the game is constantly stuttering to where it is unplayable. I also noticed that the game runs smoothly once I alt tabbed out, but I have no idea why. Have you learned anything more on this subject?
Reply Quote
Posts: 2
Also if you run SC2 in your non default display it fixes it. If you move SC2 to another display (i do it with ultramon + shift rightclick on taskbar) the FPS issue goes away

i7 920
ati 6990
3 monitors (all 2560x1400)
Edited by heapoverflow on 12/27/2012 2:36 AM PST
Reply Quote
Posts: 25
Didn't work for me.
Reply Quote
Posts: 2
Change your desktop theme from Classic to Aero - Solved it all for me
Reply Quote
Posts: 1
Rolled back my drivers to 2010, hoping it's going to reduce stuttering and unplayable 0fps.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]