StarCraft® II

Disappearing Mouse

Exactly what it sounds like, mouse cursor disappears randomly during gameplay.

Have to switch to windowed mode, cmd+tab out and back in, then move back to fullscreen.

Nothing in particular triggers it, just happens sometimes. Usually when I am in a battle. I have an external display connected with HDMI but I've never had problems with that before and have always run 2 monitors. Used to play on a macbook pro plugged into the same display with the same adapter.

Running 10.7

Model Name: iMac
Model Identifier: iMac12,2
Processor Name: Intel Core i7
Processor Speed: 3.4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 8 GB
Boot ROM Version: IM121.0047.B0A
SMC Version (system): 1.72f2



AMD Radeon HD 6970M:

Chipset Model: AMD Radeon HD 6970M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 2048 MB
Vendor: ATI (0x1002)
Device ID: 0x6720
Revision ID: 0x0000
ROM Revision: 113-C2960K-152
EFI Driver Version: 01.00.507
Displays:
iMac:
Resolution: 2560 x 1440
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort
DELL 2408WFP:
Resolution: 1920 x 1200 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: G283H96923ES
Mirror: Off
Online: Yes
Rotation: Supported
Television: Yes
Display Connector:
Status: No Display Connected
Display Connector:
Status: No Display Connected
Display Connector:
Status: No Display Connected
Reply Quote
Just happened to me too.

Early 2008 iMac running 10.7 Lion

On Starcraft II patch 1.3.6
Reply Quote
Happened to me as well.

Early 2011 Macbook Pro 15" Lion OSX

Randomly in the middle of a battle as smb said.
Reply Quote
Support Forum Agent
Thanks guys, can we get some additional hardware specs like smb posted, so we can look at this a bit further.

1. Hold the "Option" Key and choose "System Information" from the Apple Menu.

2. Copy the information from the following sections:
Hardware (remove the Serial Number line)
Graphics/Displays
Software (remove the Computer Name and User Name lines)
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Tu-Sat 8:45 am - 5 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
Small talk. Small talk... Flies. Peanuts. Dimes. Oh, and sweaters. They get muy, muy small in the wash.
Reply Quote
Support Forum Agent
Also, if you have a mouse with a middle button while playing, are you able to click that to see if it reappears?
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Tu-Sat 8:45 am - 5 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
Small talk. Small talk... Flies. Peanuts. Dimes. Oh, and sweaters. They get muy, muy small in the wash.
Reply Quote
I have the same problem.

Early 2008 Mac Pro running 10.7 Lion

Radeon 5870 video card

SC2 version 1.3.6

Clicking the middle button does not help.
Reply Quote
I have this as well. No clicks help


Model Name: Mac Pro
Model Identifier: MacPro5,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 3.2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 16 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: MP51.007F.B03
SMC Version (system): 1.39f11
SMC Version (processor tray): 1.39f11
Hardware UUID: 54CCB2AC-15E6-5E4A-B581-9BCF2CB1BAC6

ATI Radeon HD 5870:

Chipset Model: ATI Radeon HD 5870
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6898
Revision ID: 0x0000
ROM Revision: 113-C0780C-194
EFI Driver Version: 01.00.436
Displays:
SyncMaster:
Resolution: 1920 x 1080 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: HCKB501152
Mirror: Off
Online: Yes
Rotation: Supported
Adapter Type: Apple Mini DisplayPort To Dual-Link DVI Adapter
Adapter Firmware Version: 1.03
SyncMaster:
Resolution: 1920 x 1080 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: HCKB501114
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Adapter Type: Apple Mini DisplayPort To Dual-Link DVI Adapter
Adapter Firmware Version: 1.03
SyncMaster:
Resolution: 1920 x 1080 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: HCKB501149
Mirror: Off
Online: Yes
Rotation: Supported

System Software Overview:

System Version: Mac OS X 10.7 (11A511a)
Kernel Version: Darwin 11.0.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: Yes
Time since boot: 5 days 38 minutes



Anytime I play the game for more than 5 to 10 minutes it happens. It is a stock box with no fancy stuff going on.
Reply Quote
Support Forum Agent
I know this is a silly question to ask, but have you all tested different mice and made sure that the mice drivers are up to date?

I know this thread is about the courser, but I have seen this type of thing before a couple of times and it was due to outdated drivers.

I am in no way ruling out the possibility of a game mechanics issue, I just am a big fan of "Possess of Elimination".

Thanks all for your help in this mater.
________________________________________________
Klint P
Mac Tech Support for Blizzard Entertainment || Mon - Fri 1:45pm - 10:45pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
https://www.surveymk.com/s/TKL88F8 <---- Rate my Blue post here...
The Restrooms are for paying customers only!
Reply Quote
Thanks for your input Klint.

That is a fairly interesting point. I'm using a Razer Lachesis (5600 dpi) mouse which Razer has seen fit not to provide mouse drivers for. So I'm just using the stock mouse driver out of Lion. It works on every other application, however.

I'd be curious to know if others in this thread are using Razer Mice. I will try it with a different mouse later this week to see if that makes any sort of difference and report back here.

However, the mouse does work as soon as I command-m out of Starcraft and while the mouse is "invisible" it still registeres clicks and mouse movements. (ie you can control elements and click on elements in the game, the only problem is that the actual cursor itself is missing).

There is a 99.99% chance that this is due to the ATI Radeon screwing up the texture for the mouse in it's memory and that causing it to use a default which is probably a transparent overlay. Note that I'm on a multiple monitor display.

Starcraft2 also has a problem on my windows box as well (not related to this report, different symptoms but same root cause of memory of mouse pointer getting corrupted). SC2 seems to hate multi-monitor setups and I can guarantee that the SC2 code has a bug in how the mouse pointer display is being handled in multimonitor situations.

Hopefully this bug report being on a stock apple machine will allow a developer to actually hunt down the issue and crush it once and for all. I know that this "mouse corrupted" issue is something that you have seen more than once in support. I know it should be pretty easy to reproduce if someone manages to get similar hardware setup on 3 monitors.

Thanks for your help and let me know if you are able to figure anything out.
Reply Quote
same here, mouse cursor disappeared randomly. need to switch between window & full mode to fix. Totally cant play sc2 on Mac lion with slow fps & mouse cursor disappearing.
Reply Quote
it looks like this is limited to ATI/AMD gfx card macs running lion?

anyone having this happen on a single monitor setup? I am going to try turning off my 2nd display and see if that fixes it.

Also, I am using a Logitech Mouse (performance Mouse MX) with SteerMouse to drive it since the Logitech software causes all sorts of crashes and will never be fixed. I've been using this exact mouse setup for about 2 years now.
Edited by smb on 8/21/2011 4:01 PM PDT
Reply Quote
Having the same issue.

Model Name: Mac Pro
Model Identifier: MacPro5,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.4 GHz
Number of Processors: 2
Total Number of Cores: 8
L2 Cache (per Core): 256 KB
L3 Cache (per Processor): 12 MB
Memory: 12 GB
Processor Interconnect Speed: 5.86 GT/s
Boot ROM Version: MP51.007F.B03
SMC Version (system): 1.39f11
SMC Version (processor tray): 1.39f11
Hardware UUID: E4D25538-B1BE-59F6-A400-95BAAF554227

ATI Radeon HD 5870:

Chipset Model: ATI Radeon HD 5870
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6898
Revision ID: 0x0000
ROM Revision: 113-C0780C-194
EFI Driver Version: 01.00.436
Displays:
E2350:
Resolution: 1920 x 1080 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: 005NDPH59528
Mirror: Off
Online: Yes
Rotation: Supported
E2350:
Resolution: 1920 x 1080 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: 001NDUNE5230
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Display Connector:
Status: No Display Connected


Reply Quote
Support Forum Agent
K guys, found out a bit more info, and I am hoping it helps. There has been some reports of clicking on minimap with a middle mouse button that causes the same thing. Try this to see if it helps.

When this happens, hitting cmd-tab or open a chat window to restore the mouse cursor.

If this happens, then it's apart of a known issue. You can open a chat window by hitting Enter and selecting a person's name. Or you can try /r if someone has talked to you already.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
Small talk. Small talk... Flies. Peanuts. Dimes. Oh, and sweaters. They get muy, muy small in the wash.
Edited by TonyM on 8/23/2011 8:41 PM PDT
Reply Quote
Yes, middle clicking on the minimap makes the mouse cursor go missing. Hitting enter does bring it back. But, often times the mouse goes missing randomly, when that happens, hitting enter does not bring it back.
Reply Quote
Support Forum Agent
Thanks for distinguishing that for me. So these types of mouse cursor missing is not related to this type of hitting enter does not make it appear back. Though the Cmd-Tab makes it come back, is that correct?
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
Small talk. Small talk... Flies. Peanuts. Dimes. Oh, and sweaters. They get muy, muy small in the wash.
Reply Quote
That is correct
Reply Quote
seems like shutting off the 2ndary display might fix it. inconclusive so far
Reply Quote
Support Forum Agent
I'll pass on this information, thanks!
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
If you can't find it here, contact a rep direct :http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. Haala at your sheep!
Small talk. Small talk... Flies. Peanuts. Dimes. Oh, and sweaters. They get muy, muy small in the wash.
Reply Quote
I can confirm that I have both of these problems. This report is on the random disappearance of the mouse with multi-monitor setup. That issue still remains. ;(
Reply Quote
I'd like to chime in quickly and add that I am also experiencing this issue. I probably have to fix it around 2-3 times per game.

I have a triple monitor setup so it appears that pretty much anytime I go over to the left or right I'm potentially looking at losing the cursor. I can actually see the OSX standard cursor right before it gets repositioned on the active monitor, but as soon as it comes back it is gone.

Only way to fix it is to either exit fullscreen and reenter, or change the resolution in the settings panel. I'm currently playing the campaign so it's not that big of a deal but I'd be raging pretty hard if it happened to me in a ladder match!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]