StarCraft® II

SC2 sound problems with speakers/headphones

Since a few patches ago, Starcraft 2 has really been giving me crap over my sound setup.

I have a laptop computer, whose speakers suck, so I usually use headphones or a really nice pair of Harman Kardon speakers. Starcraft 2 will play sound through the speakers and headphones just fine.

If I try to play music while playing the game, the music ONLY comes out of the laptop speakers. It WILL NOT play from the plugged in speakers or the headphones. I seriously do not understand this problem.

Blizzard, please help me fix this, I have made a few posts in the past, to no avail. Tell me what you need to know. TELL ME, BLIZZARD. DANCE THE DANCE OF LIFE WITH ME.
Reply Quote
Thanks for the help blizz.
Reply Quote
Yeah I'm experiencing the same problem... My skype will work on my speakers but my starcraft sound will only come out from my laptop speakers...
Reply Quote
so what was the solution?... haha i have the same problem
Reply Quote
I have the same issue. Bumping this thread because it is important.
Reply Quote
I have the exact same issue but it's that Starcraft II's sound only comes out of the internal speakers even when it's the only program using the soundcard. I almost returned these speaker's I just bought. I thought they were broken
Edited by Cronos on 12/4/2011 6:52 AM PST
Reply Quote
I'm not sure what the issue is...if I have music playing when I start the game, and my headphones on, the music changes to play over my laptop speakers. I can manually set the game to use my headphones (normally I have it set to default), but the music will still play out my speakers. It seems as though the game actively changes your default when it starts up.

When I close the game, my sound goes back to my headphones.
Reply Quote
Wait...I think I found the solution (at least for me...maybe it will help others too):

In my audio settings, it shows both my speakers and my headphones as separate devices. I had my headphones set as my default. When I changed the default to the speakers, it seems to fix the issue (the sound was going out the speakers according to this, anyway, even when it was playing through my headphones).
Reply Quote
Same problem with my HP laptop. Tried rolling back the audio driver files and every single different setting on Starcraft 2.
Reply Quote
Ya, I am having a similar issue. I even re-installed starcraft to see if that would fix it, but it did not. Whenever I start sc2 the sound will not play through any external sound device and only plays through my laptop speakers.

I have played warcraft a couple days ago and I did not come across this problem. I am not sure what is wrong I have even played with sound settings
Reply Quote
i have a hp laptop and have the hp docking station and when i start starcraft 2 it makes my sounds come out thru the laptop speakers, did anyone ever figure out why this happens?
Reply Quote
I wish we could get some kind of response from Blizzard since this issue has clearly not been resolved.

The only way I can get it to play through headphones is if I completely disable the laptop speakers as a sound device, but than Foobar doesn't work so it's not a good solution.
Reply Quote
Issue still hasn't been resolved in anyway that doesn't involve me disabling sound devices in Windows which I shouldn't have to do.
Reply Quote
I have the same issue. When Starcraft 2 is opened, all sound will play through my speakers, but as soon as I turn Starcraft off, sounds returns to my headphones.

It seems like HP laptops have this problem, as my laptop is an HP Pavillion DV-6, and all the other problems are off of HP machines.
Reply Quote
Search 'manage audio devices'

Disable Communications Headphones.
Reply Quote
Monkeylord's solution fixed it for me. Thanks
Reply Quote
Finally got it to work. Thought I'd tried that already but I guess I was just disabling the laptop speakers
Reply Quote
Search 'manage audio devices'

Disable Communications Headphones.


Thank you! This worked!
Reply Quote
Search 'manage audio devices'

Disable Communications Headphones.


Sir, I love you. Thank you oh so very much.

I logged on just to say this.
Edited by klibrt on 2/6/2012 4:07 PM PST
Reply Quote
Search 'manage audio devices'

Disable Communications Headphones.


Finally fixed my problem. Thank you sir.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]