Broken Cursor

Posts: 9
Bringing up the Task Manager in windows restored the mouse cursor (in windows) for me...
ATI 5750...

Enable/Disable hardware mouse for SC2 ? Maybe that's the 'simple' fix that needs to be implemented?

Edited by Qxs on 8/22/2010 11:18 AM PDT
Reply Quote
Posts: 2,048
I have this issue as well.... I have a radeon HD 5750.

I've toyed around with my computer but so far the only solution I see is to restart the computer.
Reply Quote
Posts: 44
ati just released new drivers 10.8 which is suppose to fix some mouse corruption issues
Reply Quote
Posts: 13
im running AMD Phenom X6 1055t with 4gb ram and ATI radeon 5850 and i get these cursor issues as well sometimes. It doesnt go away unless u restart. Its really annoying.

im running on 10.4 drivers atm.
Reply Quote
Posts: 4
Get the same problem with an integrated ATI card. I just mouse over move or attack and it changes back.
Reply Quote
Posts: 6
Same problem ati radeon 5850.
Reply Quote
Posts: 13
Same problem here, I am running 10.7 with two 5870's cross fired. The cursor gets jagged and completely screwed up. Any new ideas on this from blue?
Reply Quote
Posts: 27
I have the same problem with my cursor, I have a Radeon 5750. My wife has yet to have this problem but she is running it on an Nvidia card, so it must be an ATI issue.
Reply Quote
Posts: 6
Still no response?
Reply Quote
Posts: 20
I'm getting this intermittenly as well with my ATI Radeon 5850. I'm using this PC (http://www.newegg.com/Product/Product.aspx?Item=N82E16883229130) with everything still stock except for the new 5850, which I bought just for Starcraft 2 and Diablo 3. I'll be very dissappointed if both of these games have issues with this video card. I was going to stay with the EVGA cards, but my motherboard only supports crossfire
(Thinking about the future).


Edit:
I forgot to mention that I was having this issue with the 10.7 driver and updated to 10.8. The issue still exists intermittenly.
Edited by Mokey on 9/9/2010 3:02 PM PDT
Reply Quote
Posts: 354
I did the suggested update and I am still having this problem. Also the problem persists outside of starcraft, it happens in starcraft but I have to restart the computer to clear the problem.
Edited by roborious on 9/12/2010 8:54 PM PDT
Reply Quote
Posts: 325
I have a ATI Radeon 5850 with version 10.8 catalyst driver and this happens after an extended time playing sc2.
Reply Quote
Posts: 1
I've seen this problem as well with a Radeon 5850 on Catalyst 10.8 and 10.9, dual monitor setup.
Reply Quote
Posts: 2
Same Issue
Windows 7 64 bit
Radeon 5770
4g
CCC 10.7
No Dual Screen Setup. It happens every time I'm in Starcraft for more than 2 games.
Reply Quote
Posts: 96
bump
Reply Quote
Posts: 64
The 10.9a application profile was released several days ago. Have you guys tried that? Not sure if that solves the problem or not.
Reply Quote
Posts: 96
I bought my computer like 24 hours ago and just updated the driver to 10.9

Reply Quote
Posts: 11
i also have this problems on my new laptop. i found that lowering my settings a bit makes this happen less frequently
Reply Quote
Posts: 96
My font settings are default, I have the latest drivers, and telling me to lower my graphics settings when i just bought a new computer is silly.

Need patch to fix this please!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]