StarCraft® II

Broken Cursor

Posts: 496
I'm not sure if another thread has a resolution for this issue, so I'm bumping this one. I am experiencing the same issue. I have an ATI card and Windows 7 64bit. The issue is more likely to occur when I minimize SC2. The glitched cursor remains when I am in game, or on the desktop doing something else. The only way I know to fix the error is to restart PC, but that is annoying. I was over at the ATI site and I couldn't find anything either, but I am at least downloading service pack 1 for Windows and an ATI update. Hopefully that fixes the issue, but is there an unofficial way to fix this issue, or temporarily without restarting PC?
Reply Quote
Posts: 517
Getting the same issue. Also using an ATI card. Any fixes on this yet?
Reply Quote
Posts: 242
Same issue. I can fix the cursor by using a trailing edge feature (which doesn't show in game) but it makes my actions sloppy.
Reply Quote
Posts: 30
Yuppers. same problem here. ATI again... hmm
Reply Quote
Posts: 130
Its a driver problem. A quickfix is to go to your mouse settings and turn Pointer Trails ON, and just shorten them to the smallest setting.

Its a bug with the ATI drivers. Make sure you keep updating your drivers too, I've turned trails off and haven't had this problem for a long time... I'm pretty sure it's because I updated my video drivers recently
Edited by endo on 8/11/2011 1:29 AM PDT
Reply Quote
Posts: 1
Bump.
Reply Quote
Posts: 606
the same thing happens to me.

to fix the problem... move your mouse left and right very fast,, over and over... works every time for me.

just move your mouse left and right... fast.. over and over... for about 7 seconds.... it always fixes it for me.
Reply Quote
Posts: 606
obviously.... its only a tempary solution.. but it an easy fix.
Reply Quote
Posts: 572
Im still getting this cursor crap 3 years later...
Reply Quote
Posts: 1
08/11/2012 01:25 AMPosted by Adiyen
Im still getting this cursor crap 3 years later...

me too..
bump
Reply Quote
Posts: 34
This hasn't happened to me for a long time--until now. This bug seems to have persisted into HotS.
Reply Quote
Posts: 2
Seems to be happening to me in HotS too
Reply Quote
Posts: 8
Ahoy! Arghmyliver here! This cursor issue happens to me all the time! I have an ATI graphics card too - Radeon HD6850.

This has happened to me for the ~2 years I have had this machine.
Here are some SCIENCE FACTS about this glitch.

There are TWO (2) iterations of this glitch

1. Your cursors distorts completely leaving you with a fractalized variation of its normal state. (strange bar pattern). I have found you can normally fix this issue by Alt-Tabing to an open window (such as an internet browser) and dragging the mouse to the top right of the screen OR forcing it to change onscreen to a different cursor (like the text cursor). This leads me to my current ingame fix which is:
A. AltTab furiously
B. Flail wildly with the mouse

HOWEVER sometimes -

2. Even after you have fixed this first glitch - your mouse cursor will be improperly drawn on the screen usually with 2 bars out of place/dark bars through it/ looks messed up. At a reasonable resolution this is almost unnoticeable while navigating the windows explorer/desktop - but becomes more apparent ingame where the mouse cursor is much larger.

The second iteration of this glitch I have been unable to solve with out a full machine restart.

Cheers!
|Argh|
Edited by Arghmyliver on 4/29/2013 2:10 PM PDT
Reply Quote
Posts: 3
I get this problem all the time on my laptop. This thread is over 2 years old. No solutions yet?
Reply Quote
Posts: 12
I check on this problem every few months to see if anything really fixes it.

I've had this for several years, on different machines, different Windows OSes, with different ATI cards. The Googlebird says others have had it for almost a decade - back to when XP came out - with various games. ATI is notoriously silent about it. I've seen a few ATI release notes that mumbled about trying to fix cursor related problems. But it still happens.

Many people recommend updating drivers, but there's no evidence that it fixes it. It's an intermittent problem, and whatever you did last makes you believe that's what fixed it. The testimony of many people on the web that driver updates do not generally fix it makes it clear.

Some say that wiggling the mouse back and forth, especially if you have multiple monitors, will fix it for awhile. That has never worked for me. The enable mouse trails fix doesn't seem to last long for me. Reboot fixes it for a day or 2.

It goes away for awhile, and comes back. It strikes me as a memory corruption issue in the card - not that the card is broken, necessarily, though possibly it is. But perhaps 2 programs attempt to update the cursor, and you get the combination as a result. So I think maybe ATI's graphic API is possibly screwed up for even allowing that to happen. So ATI engineers probably blame Microsoft and Blizzard, and Blizzard probably blames ATI, though I've never seen even a remote trace of a comment from any of the companies involved.

Many people advise replacing the card with Nvidia. I'm slowly coming to agree with them. 10 years is plenty of time to fix a problem.
Reply Quote
Posts: 30
2014, I still get this problem....
Reply Quote
Posts: 94
09/14/2011 12:22 AMPosted by Fireblazzer
he same thing happens to me.

to fix the problem... move your mouse left and right very fast,, over and over... works every time for me.

just move your mouse left and right... fast.. over and over... for about 7 seconds.... it always fixes it for me.


This worked for me too! Thanks!!
Reply Quote
Posts: 1
Still having this issue too. Have had it since the start of Wings of Liberty. It's sad to see that after four years there is still no solid fix.
Reply Quote
Posts: 4
I'm still getting this problem too :S
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]