StarCraft® II

Shift key Bug problem

For those of you who are having problem with shift key while making nonstop spawn of units or using a spell ability. I might have found a solution on how to fix left shift bug.

I just recently bought new computer vaio laptop to play the game with better graphics and found out that i have same problem as many other people while playing the game. Looked for a solution for about 2 hours about how to fix the problem and nothing seemed to work as some other players explained extra solutions on how to fix the lagging shift bug.

All i did was run program as administrator . That has fixed the problem for me, it only works for laptops i guess because desktops seem to be barely having that problem. It also worked for a few of my friends who also play the game.

For those of few who don't know how to run game as administrator do the following:

If you have a StarCraft 2 shortcut on your main screen when it starts:

1) Right-click on the shortcut for additional options to open
2) On the very bottom go to Properties
3) Then when you look on top of the link the following links will show such as "general" , "shortcut", "compatibility" etc. Click on Compatiability
4) Almost on the bottom it will say Privilege Level and right below that, check the mark that says Run This Program as Administrator
5) Click apply, then ok.

After that run game and it will be saying alot of stuff just press YES. All its asking if you want to run program as administrator.

If that does not solve the shift bug problem do the following:
1) Do as directed up to step 4 as i explained in earlier
2) On very top it will say Run This Program in compatibility mod for check that.
3) After if the option right below that does not say Windows XP service pack #, make sure to pick that option.
4) Click Apply, then ok.

Should be working without the shift bug.

P.S. want feed back from people who tried to solve problem in a way i did it. If that still doesnt work for you. you are free to add me and say that it didnt work and i will try to come up with other solutions aside the ones that already exist.

I hope it will fix the problems for you. Just trying to help out the community :)))
Reply Quote
More then a year later for a replay, but ok, let's go.

I suffer with this same problem, and i have already lost up to 4 matches directly because of this error, and more then 7 because of it's interference, so, you see, I'm pretty desperate. If I don't get ant results, I might just stop playing the game. No point to play if the own game systematic defeats me.


Right now I just tried your first step, and I almost laugh: the first click i gave was bugged already.

Tried a second match now: still with the problem.

Already played with other keyboard: still the same.

Can someone help me?
Reply Quote
yes look at (win7) center for easy control - keyboard - deactivate key delay or smth like that. I had it activated automatically due to a program that reduces delay from 500ms (windows 3/4) to 375, because 250 (win: 4/4) was too low.

and search in this forum . already answered by blizz.
Edited by DoOmTrAin on 4/5/2013 9:38 AM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]