StarCraft® II

StarCraft II - Patch 1.5 Mac OS X 10.5 No Longer Supported

Posts: 49
Then why don't you guys communicate with Apple and maybe checked to see how easily it was to upgrade OS before you decided to throw us out into the cold?
Reply Quote
MVP - Technical Support
Posts: 9,713
it was easy, 3 years ago, when people should have upgraded. 10.6 was a significant update over 10.5. it updated opengl massively over 10.5.8, optimized the intel code signifcantly. added a ton more 64 bit support. cleaned out a bunch of obsolete junk. ifeature wise it wasn't much of a user interfae change from 10.5, but the update was so sigifnicant, at the time most games required it upright immediately after it came out, any new game pretty much required it. sc2 was generous up to this point but it's since evolved to point it can't tolerate such obsoleteness any longer.

as for upgrade, it's still easily gottem off amazon, unfortunately the price has gone up over the years (not down). do to quantity contraints and what not. none the less, once you get to 10.6.8, any step beyond that becomes easay with app store, should you want to continue up to 10.8 if able. 10.7 unfortunately is near impsosible to find. from apple or anywhere else. which is dumb on their part, since they knowingly dropped a few macs from 10.8s support, making 10.7 the latest some macs can currently grab. apple, however, has never been a company that really cares about their users after 2 years. they operate on pretense hardware should be replaced as often as you buy socks. :\

Apple makes great stuff, they just don't support it very long. you have to move with the times as an apple user. that's their design.
Edited by Omega on 7/31/2012 9:41 PM PDT
Reply Quote
Posts: 12
This is the first time I've bought a game that changed its system specifications after it initially described them. Continued support for older operating systems should be possible, or people should be allowed to run the game in the patch 1.4 version! Why can't we run the game in the previous patch? Is there anyway to make the 2 patches compatible for multiplayer play? I bought Warcraft III The Frozen Throne and that still works on the system specs described initially, why can't starcraft? This is ridiculous... I'm going to have to buy a new computer to continue playing a game that's about two years old. I'm not even sure if I can support 10.7.x because I don't know if I have a 34 bit or 64 bit processor.
Reply Quote
Posts: 49
Yes but why would we have needed to upgrade, we didn't know you guys were going to blindside us until basically today.

You still haven't answered my other question. Why didn't you look to see the repercussions when this stupid idea came into your heads? Did you think "Oh, well it must be easy to upgrade OS". Did you even check to see if it was possible? Did you even think about what your paying customers would feel when you gave them the shaft, and told them you couldn't play the game that you loved? What if I told you that you couldn't use a computer, or you couldn't work at your dream job? How would you feel? At least give us our money back if you're gonna kick us to the curb.
Edited by Corazon on 7/31/2012 9:39 PM PDT
Reply Quote
MVP - Technical Support
Posts: 9,713
07/31/2012 09:35 PMPosted by Jesse
Warcraft III The Frozen Throne and that still works on the system specs described initially, why can't starcraft

cause one game is current and one game is no longer getting content updates?

07/31/2012 09:35 PMPosted by Jesse
This is the first time I've bought a game that changed its system specifications after it initially described them.

when 10.6.3 came out, a bunch of games in steams library immediately switched to new opengl 3.x extentions and as such upped the games requirements to 10.6.3+ since as of 10.6.3 and later, 10.6 supported 22/23 opengl 3.0 extentions, and some minor omes from 3.1 and 3.2, greatly adding functionality to games that could use them vs the apis from 10.6.2 and older that had pretty much nothing beyond 2.1 apis. point being,many games that were still being maintained, changed their requirements. granted any game NOT being maintained did not, but that falls into same catagory as warcraft 3.
Reply Quote
Posts: 3
Not good enough Omega.

The solution is not to make it so we can't play at all. The solution is to stop allowing us to update the game. Let our version of the game become as obsolete as our system is. Make it so we can only play offline. Whatever, but don't kill the game. That's just stupid business. And really hurts my opinion of Blizzard games.
Reply Quote
Posts: 400
07/31/2012 09:33 PMPosted by Omega
it was easy, 3 years ago, when people should have upgraded.


Screw you. I've lost too many files, programs, and hours of my life when the new version of an OS, even Macs, decides it doesn't like what I've been successfully using on the same hardware. There are always problems, some files don't end up where they're supposed to go, some driver bugs out, something happens. Especially when you start talking about API changes. There was zero reason to switch three years ago. Hell, I'm already upset b/c I can't get D3 yet. I'm probably more upset w/ Apple, b/c there's no reason they can't offer 10.6 on their download store. That's pathetic.

But there was no reason Blizzard needed to do this, either. I've supported them for years b/c A) they were nice to us Mac users, and B) they didn't force you to buy a new super system every other year just to play their games. W/ Apple planning on rolling out "big" updates every year or so, Blizzard shouldn't fall for that trap. Hell, D3 can play on Windows XP, but not 10.5. What's up w/ that crap?
Reply Quote
Posts: 12
umm... I still want to play the game online. Playing online is where you get the most fun.
Reply Quote
Posts: 11
AGREED.

If players really need to be able to see dust and smoke more clearly (basically reason for "updates"), make those who want it buy a new version of the game (ie starcraft 3) instead of shutting down the game to those who have already bought it.

Instead, have to buy a new comp to play a game I already bought.

Flippin ridiculous.....
Reply Quote
Posts: 12
The solution is to make the old patch compatible with the current patch, and to make it optional to patch the game. That way the system requirements would stay the same and there would be no problem. Sure we wouldn't get the "improved" setup for how to join games and the arcade, but at least we could continue playing on ladder. I just want to keep playing on ladder, and since this patch didn't adjust any balance issues between races, can't you simply make the patches compatible for online play?
Reply Quote
Posts: 1
I fully agree with a lot of people here. If anything leave an outdated server for us. Even when other console system says they drop support for a game, for the most part a few servers are still running for the users. I've never had a game that just stop working especially from an update. Even worse I've never had a game where the system requirement changes from the minimum requirements written on the box. I spent $100 on this game and I would like to play it, which unfortunately right now I can't do that.
Reply Quote
Posts: 11,250
07/31/2012 05:04 PMPosted by IronManSC
Is blizzard going to discontinue 10.6.8 after HotS/before LotV? If so you can say goodbye to me.
Reply Quote
Posts: 20
Howdy Mac users, while I do not own a Mac I have to say I agree with what many of you here are saying.

Hope it works out for all of you
Edited by Battleaxe on 7/31/2012 11:22 PM PDT
Reply Quote
Posts: 49
07/31/2012 11:16 PMPosted by IronManSC
Is blizzard going to discontinue 10.6.8 after HotS/before LotV? If so you can say goodbye to me.


Yes that is most likely. And this will keep happening to Mac users until they just decide that no one can play SC on a mac.

In all honesty 10.6 might get phased out before HotS.
Reply Quote
Posts: 8
Great. My 10.5.8 is acts like an idiot you can't even talk to. I would love to play the campaign now that you took away my online play...oh wait, can't do that either. Thanks Blizzard. Can I get my 60 bucks back? And thanks for giving me absolutely no warning...you have my e-mail address a little notice would have been nice.
Reply Quote
Posts: 15
I guess it was my fault for not realizing I was purchasing such an unfinished game.
Reply Quote
Posts: 12
07/31/2012 11:43 PMPosted by KoalaTeaTime
I guess it was my fault for not realizing I was purchasing such an unfinished game.


You're not alone there buddy. This is utter negligence.
Reply Quote
Posts: 49
Hopefully I'll wake up tomorrow and hope this was all a bad dream.
Reply Quote
Posts: 19
07/31/2012 06:12 PMPosted by KoalaTeaTime
I don't understand, if you knew the system requirements would change why wasn't it on the box? Do I get a refund? I feel like I bought a car and the dealership told me there was a recall on the tires my car came equipped with and had to be replaced with bigger better tires, but too big for my car to actually turn the axle with. I said no! I don't want these tires but the dealership insisted.


This is not right. I purchased a game that said it would run on my system. Updated game will not run on my system.
Reply Quote
Posts: 11,250
Did blizzard expect us within a month's notice to find that spare $1700 and go buy an entirely new computer with a stupidly 0.1.0 OS upgrade just to RUN starcraft?

Well lads, enjoy Ohana as much as you can, cuz there will be no more maps coming from me. Now I have truly become the frowny siege tank man.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]