StarCraft® II

No sound at all.

Posts: 26
Hi all,
I've gone through about 80 threads on here about how to fix this problem but none of the quick fixes seem to work for me. Switched to 5.1 sound, stereo, mono, and all options in between but I am still getting no sound (from any program at all) while Starcraft is running. I'm running Windows 7 and went to the HP website to make sure I was running the most up to date driver. I've gone through the speaker and audio setting in Windows to make sure they were set to 5.1, and then to stereo, restarting the game each time to try to match up the setting but to no avail. Any help would be much appreciated :D
Reply Quote
Posts: 2
I have almost same problem.

Before my output device was at default and by changing it I was able to hear the game sound.

Although, I still can't hear any other sounds from other programs.
I have read most of the threads on the subject and I can't find anything neither.
Reply Quote
Posts: 3
I Have the same problem i just had it happen to me tonight.
I was listen through headphones when I alt tabed out of SC2 and unpluged my headphones in the process, when I alttabed back into game i have no sound
Its driving me crazy
Ive spent two hours now reading everythread aviable on the subject and trying all the fixes none have worked for me also
Ive gone through and reset everything back to default and when i say eveything i mean everything from ingame options to my computer audio options
I checked all the things Hongkai said
Tonight im going to reinstall if this doesnt fix it I dont know wat to do
SC2 is near unplayable without sound as a RTS for me
Some Support soon is needed should I provide me dxdiag? ill list it hear and check back in the morning :_(

Time of this report: 6/17/2012, 22:53:28
Machine name: LUIS-PC
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120503-2030)
Language: English (Regional Setting: English)
System Manufacturer: To be filled by O.E.M.
System Model: To be filled by O.E.M.
BIOS: BIOS Date: 10/20/10 09:47:36 Ver: 08.00.10
Processor: AMD FX(tm)-4100 Quad-Core Processor (4 CPUs), ~3.6GHz
Memory: 8192MB RAM
Available OS Memory: 8138MB RAM
Page File: 2354MB used, 13918MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
Card name: ATI Radeon HD 5700 Series
Manufacturer: Advanced Micro Devices, Inc.
Chip type: ATI display adapter (0x68B8)
DAC type: Internal DAC(400MHz)
-------------
Sound Devices
-------------
Description: Speakers (High Definition Audio Device)
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_10438436&REV_1003
Manufacturer ID: 1
Product ID: 65535
Type: WDM
Driver Name: HdAudio.sys
Driver Version: 6.01.7601.17514 (English)
Driver Attributes: Final Retail
WHQL Logo'd: Yes
Date and Size: 11/20/2010 20:23:47, 350208 bytes

Someone plz help me!
Reply Quote
Posts: 2
I found something interesting today. When I am on a skype conversation before playing stacraft 2, all the audio set up work beautifully.

Somehow this resets everything to default and i can hear all the music from starcraft and any other music at the same time.

At least we have that!
Reply Quote
Posts: 27
I figured out what the problem was. In the control panel under Hardware and Sound, head into that specific device's information (the headphones/speakers). In here, under the Advanced tab, there's an option to "Allow programs to take exclusive control of this device"

Disable this checkbox and you're good to go! <3
Reply Quote
Posts: 1
I've tried all of the sound options and I changed the control panel option as well. My audio works with everything except when the game is launched. Please help?
Reply Quote
Posts: 16
did not help at all
Reply Quote
Posts: 2
I just had the same problem. Was running Ventrilo and have my hotkey set to left ctrl. I think the disable sound command is ctrl+s or something. I went into the sound options and the enable sound box was unchecked; enabled sound again and it works. Give it a !@#$.
Reply Quote
Posts: 109
WAAaaaaahh!!!... WAaaaaah~ no soooooouuuund~~~ help me~~
Reply Quote
Posts: 1
click sound thing by clock on bottom right, see the name of the driver its running on. for me it looked like headphones, then just match it it with the one in the game settings. this worked for me atleast.
Reply Quote
Posts: 2
I found a fix for mine, a wierd one.

Control panel>
sound>
Communications tab >
"when windows detects a communication activity"
check the "do nothing" box.

Win!
Reply Quote
Posts: 3
The solution from the starcraft II support page worked for me. In starcraft go to Options,Sound, under Setup use the dropdown to select your output device. It was on Defaut instead of my headphones. I got the no sound issue when I connected my laptop by HDMI to my TV to watch a movie and then play D3. I had also right clicked on the sound icon in the Taskbar to check that my headphone were set to default.
Reply Quote
Posts: 1
I had the same problem and after reading all the forums whit no resoult ... i pusht CTRL + S and everything works perfecly. CTRL + S work in the menu too, you dont have to be in a game to use the shortcut.
I hope it works for you too
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]