StarCraft® II

SC2 1.5 won't launch

Posts: 9
Same problem as most others here. I downloaded the patch 100% before pressing Play. I was able to log on and play a few customs, but then I went to play again later and the program stops responding and forces me to quit. Upon quitting it says that some files are missing and I need to reinstall (even though it worked fine earlier). Here's my system info:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro8,1
Processor Name: Intel Core i5
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 4 GB
Boot ROM Version: MBP81.0047.B27
SMC Version (system): 1.68f98
Hardware UUID: 9E34998B-F7DD-5BF4-9E93-2FBE2451D838
Sudden Motion Sensor:
State: Enabled

Intel HD Graphics 3000:

Chipset Model: Intel HD Graphics 3000
Type: GPU
Bus: Built-In
VRAM (Total): 384 MB
Vendor: Intel (0x8086)
Device ID: 0x0126
Revision ID: 0x0009
Displays:
Color LCD:
Display Type: LCD
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Software Overview:

System Version: OS X 10.8 (12A269)
Kernel Version: Darwin 12.0.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
Time since boot: 23:09

Thanks for working on this for us! I hope to hear of a solution in the near future!

**EDIT**
The reinstall worked the same as before. I played a couple customs, then I quit, and upon returning I get an application that doesn't respond and claims that some SC2 files are missing.

**EDIT 2**
I was finally able to reopen the game after trying out part one of the solution in this thread:
http://us.battle.net/sc2/en/forum/topic/6233033632?page=6#103
However, now my problem is that SC2 stops responding when I try to exit the program. Every time I want to play, I have to delete my Starcraft Folder.
Edited by iFoundWaldo on 8/1/2012 11:14 AM PDT
Reply Quote
Posts: 5
Same issue:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro5,3
Processor Name: Intel Core 2 Duo
Processor Speed: 3.06 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache: 6 MB
Memory: 8 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MBP53.00AC.B03
SMC Version (system): 1.48f2
Serial Number (system): W894426L64C
Hardware UUID: 4CC34149-E921-56FA-BE94-967D8FBAE4B4
Sudden Motion Sensor:
State: Enabled

NVIDIA GeForce 9400M:

Chipset Model: NVIDIA GeForce 9400M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0863
Revision ID: 0x00b1
ROM Revision: 3448
gMux Version: 1.8.8
Displays:
Color LCD:
Resolution: 1440 x 900
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

NVIDIA GeForce 9600M GT:

Chipset Model: NVIDIA GeForce 9600M GT
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0647
Revision ID: 0x00a1
ROM Revision: 3448
gMux Version: 1.8.8
Edited by FalconK on 8/1/2012 1:42 PM PDT
Reply Quote
Posts: 1
so anyone find the fix for this yet?
Reply Quote
Posts: 3
Yup im running a macbook pro and since the last update i can no longer play. I try to launch the game and the updater(although i already got the last patch) will pop up and display 0% updated. Then sc2 will quit after a few minutes.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]