StarCraft® II

Failed to read a required file.

Posts: 11
This came up after the launcher loads. This is after I downloaded the patch and went through troubleshooting when the game didn't load. I've deleted Users/shared folders, changed launcher to enUS, and moved blizzard folder to desktop from library/preferences.

Model Name: MacBook Pro
Model Identifier: MacBookPro4,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.5 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 6 MB
Memory: 4 GB
Bus Speed: 800 MHz
Boot ROM Version: MBP41.00C1.B03
SMC Version (system): 1.27f3
Hardware UUID: 2B1B51F7-43FF-5378-A6F6-CAEF90FD2053

Chipset Model: GeForce 8600M GT
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0407
Revision ID: 0x00a1
ROM Revision: 3212
Displays:
Color LCD:
Resolution: 1440 x 900
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Display Connector:
Status: No Display Connected

System Version: Mac OS X 10.6.8 (10K549)
Kernel Version: Darwin 10.8.0
Boot Volume: MacBook Pro
Boot Mode: Normal
Secure Virtual Memory: Not Enabled
64-bit Kernel and Extensions: No
Time since boot: 1:01
Edited by Dan on 8/1/2012 11:04 AM PDT
Reply Quote
Posts: 11
Should I just reinstall? :(
Reply Quote
Posts: 10
Found a solution that worked for me on this error. See details here:
http://us.battle.net/sc2/en/forum/topic/6607191971?page=1#12
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]