An internal error has occured...

Posts: 28
So far I could play but today it's impossible! And I didn't do anything to my client since the patch so I guess the error comes from blizz isn't it?
Reply Quote
Posts: 1
excact same thing. interanal error has occured is there a fix yet?
Reply Quote
Posts: 11
I was having trouble connecting both SEA and NA servers after the big patch. Managed to fix the problem but not sure which part it was. I use windows 7.
Changed the main sc2 folder (you can right click then open file location) settings from read only as well as checked the security settings to make sure system, admin and <myuser> were present. I then went to my docs, sc2 folder. I had some login username shortcuts that were not present before so I deleted them. I then repeated the same security settings on the my docs sc2 folder.
Reply Quote
Posts: 38
i have this problem also tried re installing and using switcher
Reply Quote
Posts: 3
Is there a solution for this yet???

I cant seem to fix it with any of these ways.
Reply Quote
Posts: 22
Glad so many people can't play the game that they bought.
Reply Quote
Support Forum Agent
Posts: 31,516
Please confirm whether you've deleted the Battle.net cache folder.

If you can't see or find this folder, here's how to show it.
________________________________________________
Technical Support
http://us.battle.net/support
'Constant change is here to stay.'
Reply Quote
Posts: 1
I tried deleting the Battle.net cache folder and the issue did not resolve.
Reply Quote
Support Forum Agent
Posts: 31,516
Can you also remove the Blizzard Entertainment folder in C:\ProgramData ?
________________________________________________
Technical Support
http://us.battle.net/support
'Constant change is here to stay.'
Reply Quote
Posts: 12
Deleting battle.net/cache and Blizzard Entertainment folders didn't resolve this. I am on a Mac. I see this in the server logs, perhaps it will help:

(com.blizzard.agent)
Request Issued to non-existent Uri: GET - /game/s2_enus
Request Issued to non-existent Uri: GET - /install/s2_enus
Request Issued to non-existent Uri: GET - /update/s2_enus
Request Issued to non-existent Uri: GET - /gamesession/s2_enus
Request Issued to non-existent Uri: GET - /backfill/s2_enus
Edited by STGvirus on 9/2/2012 2:04 PM PDT
Reply Quote
Posts: 38
i used the uninstall guide and still not working ...
Reply Quote
Posts: 1
Well, it looks as if we have some time on our hands before this gets fixed...
Reply Quote
Posts: 4
This should work ...

Right click sc2 icon go to properties > compatibility tab > tick the "Run in compatibility mode" for windows 7 > apply

glgl hf ¯\_(ツ)_/¯
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]