StarCraft® II

Patch 1.5 CPU usage problem.

Posts: 55
Got around to finally launching the game (after having to delete/re-download/install/patch because of the patcher not responding issue)!
First thing I've noticed (besides the UI) is that now the game eats up CPU like crazy! In 1.4 it was idling at 40% between the cores, however in 1.5 one core is maxed at 100%!

http://i.imgur.com/Pq8l2.png

System specs:
Model Name: Mac Pro
Model Identifier: MacPro3,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.8 GHz
Number of Processors: 2
Total Number of Cores: 8
L2 Cache (per Processor): 12 MB
Memory: 8 GB
Bus Speed: 1.6 GHz
Boot ROM Version: MP31.006C.B05
SMC Version (system): 1.25f4

Chipset Model: ATI Radeon HD 5770
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x68b8
Revision ID: 0x0000
ROM Revision: 113-C0160C-155
EFI Driver Version: 01.00.436
Edited by Mhorbid on 7/31/2012 5:05 PM PDT
Reply Quote
Posts: 8
same here, my cpu usage 100% while playing, i'm using 15' MBP 2008 later. cpu is core duo 2.6g. fix this please!
Reply Quote
MVP - Technical Support
Posts: 9,808
i'm trying to see what the problem is here though? the game is actually using your hardware. but that alone isn't a bug, unless it's stuck on a process it shoudln't be stuck on causing other things in game to degrade. but if game is running fine at 100% cpu, then it seems fully intended. both wow and D3 run 100% cpu, sc2 honestly never used enough cpu before. i'm betting 10.5 fixed that. cause it'd lag wheer it shouldn't lag on my machine before. and i have same machine as op. 100% of one core is very normal. in fact, since blizzard games only use 2 cores anyways they tend to max 1 core to 100% and another to like 10-30%, resulting in total core usage of about 130% on my mac pro 3, 1 when playing any of their 3 games.

just using the cpu is not a problem. using the cpu frivilously ausing the game to run very poorly is. but unless you're getting like much lower fps then 1.4 or something. doesn't sound broken.
Reply Quote
Posts: 6
I also notice this and an increase in temp also.

looks like about 10 deg higher after patch.

anyone else see a temp increase?

this is not in game either just in the menu.

I'm scared to see what a battle in 2v2 will bring.
Reply Quote
Support Forum Agent
Posts: 14,784
I'll send this feedback up to the team for review.
Reply Quote
Posts: 8
same here, cpu usage 100% (2core 100%)and game lagging unplayable.
Edited by zBS on 8/1/2012 7:20 PM PDT
Reply Quote
Posts: 6
Hey, mark me as another major lag datapoint. The game's never been speedy, but it's nearly unplayable post-patch. I know a MBP isn't a gaming machine, but it still shouldn't get too much WORSE over time for the same game?
Reply Quote
Posts: 1
I am having the same issues it maxs my CPU to 100% and then it will just drop me from online games, even the simple ones. it has made the game unplayable.
Reply Quote
Support Forum Agent
Posts: 14,784
Can you post your full system specs?

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]