StarCraft® II

Custom Race created... but cannot publish.

Posts: 4
I have finally finished my custom map after about a week fine tuning everything, however since I added a new race the map will no longer publish. I get an error message saying something like 'Default attributes could not be validated' After a lot of searching I have come to the opinion that it has to do with the melee triggers. Is this true? Whatever the case maybe could someone please link or create a step by step process of how to get your map published and playable with a custom race added. I really don't want all of my work to be for nothing. All player attributes and game variants match... but I am guessing the default values are affected by adding a new race. Any help would be appreciated.
Reply Quote
Posts: 105
I also encountered this problem and was forced to get rid of my custom races (and use a dialog for my hero pick instead)

One thing that might help you though is in the races tab when you create a new race, it needs an attribute ID, have you changed that for your new race?
Reply Quote
Posts: 8
Ive had the same problem.
Reply Quote
Posts: 8
Ive found a possible solution, its simple lol. Set the custom race to "defines default values" and it worked for me.

Edit: Yeah but now the race isn't selectable in lobby....
Edited by Notzerg on 11/12/2012 3:21 PM PST
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]