StarCraft® II

[Bug] Pink Waters

Posts: 2,165
Hello,

I didn't report this earlier (it appeared around post-patch 1.5) because I assumed Blizzard would have fixed it already. Anyway, on some maps (I'm not sure if it's on all maps, probably yes if there is water textures in it) the water will become solid pink. I mean completely solid pink with no water texture at all. It's especially annoying on maps such as Ohana LE which has water all around the corners and less noticeable on Tal'darim Altar where there's a pocket of water in a certain spot on the map.

Either this needs to be patched or is there some sort of fix that would remove the annoying pink textures from areas that has water textures?
Reply Quote
Quality Assurance
Posts: 3,363
Greetings sceadulord,

Could you please post your dxdiag to help us investigate this?

Please be sure to mention whether you are using an SLI / Crossfire setup or not in addition to the following:

If you have a Windows PC, we will need the following information from your DxDiag:

To obtain a DXDiag:

Press the Windows Key + R at the same time.
In the Open: field type in dxdiag and click the OK button.
Click Save All Information, then open the file and copy the requested information into your post.
• Operating System:
• Processor Info:
• Ram Info:
• Direct X Version:
• Card Name:
• Manufacturer:
• Chip Type:
• Device Identifier:
• Vendor ID:
• Device ID:
• Display Memory:
• Current Mode:
• Native Mode:
• Driver Version:
• Driver Date/Size:
• Sound Card Name:
• Sound Driver Version:
• Sound Driver Date/Size:

If you have a Mac, we will need the following information from your system profile:
To obtain a System Profile:
Open the Apple menu and choose About this Mac.
Click "More Info..."
• Copy the requested information into your forums post.
• OS Version:
• Processor:
• Graphics Card:
• Memory:

Thanks,
Kelphe
Reply Quote
Posts: 2,165
Kelphe,

I hope the information containing what you have requested helps in finding a solution to this problem regarding pink textures where there used to be water textures.

• Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120503-2030)
• Processor Info: Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz (8 CPUs), ~2.3GHz
• Ram Info: 8192MB RAM
• Direct X Version: DirectX 11
• Card Name: Intel(R) HD Graphics 4000
• Manufacturer: Intel Corporation
• Chip Type: Intel(R) HD Graphics Family
• Device Identifier: {D7B78E66-4226-11CF-707C-0F71A9C2C535}
• Vendor ID: 0x8086
• Device ID: 0x0166
• Display Memory: 1696 MB
• Current Mode: 1920 x 1080 (32 bit) (60Hz)
• Native Mode: 1920 x 1080(p) (59.906Hz)
• Driver Version: 8.15.10.2712
• Driver Date/Size: 3/26/2012 07:09:58, 8087040 bytes
• Sound Card Name: Realtek Digital Output (Realtek High Definition Audio)
• Sound Driver Version: 6.00.0001.6526 (English)
• Sound Driver Date/Size: 12/13/2011 06:27:30, 4718952 bytes


I wanted to mention that my laptop has the Nvidia Optimus Technology so when I'm gaming it automatically switches to GeForce GTX 670M. So if you requested information for that then it'd be something alongside the lines of:

• Card Name: Nvidia(R) GeForce GTX 670M
• Manufacturer: Nvidia
• Chip Type: Nvidia(R) GeForce GTX Graphics


The above isn't official but modified to the best of my ability to follow the expectations as shown in the first quoted block.

Thanks.
Reply Quote
Posts: 2,165
Update: Either the recent patch, your investigation into this, or something else happened because I don't see pink textures where water used to be anymore, instead, I see water now! I'll post again if anything else comes up or changes. I'm being a cautious optimist for now.
Edited by sceadulord on 9/19/2012 4:59 PM PDT
Reply Quote
Posts: 4
I'm having the same issue on one of the computers i use. The Other one is fine but this one isn't. all water is pink no matter what map. Starcraft 2 editor shows water in normal color. Tried a repair and that didn't help. Re-installed Starcraft 2 and it fixed the issue until yesterday. So now i have pink water again. :(

• Operating System: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1
• Processor Info: AMD Phenom(tm) II X6 1090T Processor (6 CPUs), ~3.2GHz
• Ram Info: Corsair CMZ16GX3M4A1600C9 4x4GB
• Direct X Version: DirectX 11.0
• Card Name: NVIDIA GeForce GTX 470
• Manufacturer: NVIDIA
• Chip Type: GeForce GTX 470
• Device Identifier: {D7B71E3E-458D-11CF-7C5B-7F341DC2C535}
• Vendor ID: 0x10DE
• Device ID: 0x06CD
• Display Memory: 4049 MB
• Current Mode: 1920 x 1080 (32 bit) (60Hz)
• Native Mode: 1920 x 1080(p) (60.000Hz)
• Driver Version: 8.17.13.142
• Driver Date/Size: 5/15/2012 05:48:00, 18044224 bytes
• Sound Card Name: Creative SB X-Fi
• Sound Driver Version: 6.00.0001.1348
• Sound Driver Date/Size: 7/7/2010 17:16:24, 697816 bytes
Edited by xFHxHOtShoT on 9/26/2012 2:26 AM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]