[Bug] AlphaMaskTexture only works when zerg

Posts: 138
The new option in the UI editor for frames that allow you to specify a frame mask (AlphaMaskTexture) only seems to function when my race is set to zerg.

Here is a test map if you need it: https://dl.dropbox.com/s/9t34cgmcc60u2ml/testmask.SC2Map?dl=1
Reply Quote
Posts: 222
Hey LinkD, we had our QA team look into this and they were not able to reproduce the issue as you've described it.

Quoting them, "Took the player's test map and tweaked it so it is easier to tell what's going on (he was using an animated portrait model, I changed it to a plain white image so the edges were clear). There's no difference between how the image (or the portrait originally included) displays between all three races. All the races mask out the image with no gradient."

Is there any additional information you can provide to help us reproduce this?
Reply Quote
Posts: 138
I just tested it again and it seems that while zerg works perfectly fine for me, when I am Terran or Zerg, the mask will only work properly when my shader is set to Low or Medium.

So it seems (for me at least) that, the mask will not work if my race is Terran/Protoss, and my shader is set to High or Ultra. This is with all other graphics settings set to as low as they can go.
Edited by LinkD on 11/15/2012 9:29 PM PST
Reply Quote
Posts: 605
From my test. This issue has already been fixed in 2.0.1 beta
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)