StarCraft® II

massive frame rate drop after update.

Posts: 3
After doing the update the game will drop to 12-14 FPS regardless of graphic setting after about 10-15 seconds of gameplay.

This issue was not present prior update. It has made game unplayable. I can have nothing on screen and have a 1v1 match vs AI and framerate will always drop after 10-15 seconds of gameplay.

Issue is present in all campaign missions as well.

late 2010 MBP 2.66 Intel Core i7 8 gb ram Nvidia geforce gt 330m
Reply Quote
Posts: 2
I too am having almost unplayable frame rate dropping - 8-9FPS instead of usual 35+ FPS on
EDIT: I have the same exact MBP as the original poster.
Edited by MinusPoints on 12/9/2012 1:37 PM PST
Reply Quote
Support Forum Agent
Posts: 14,784
What update? The 1.5.3 update or the recent tools update?
________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
Edited by Machkhan on 12/9/2012 1:37 PM PST
Reply Quote
Posts: 3
the edit that came out on friday....the 1.5.3 update......it rather sucks because it tricks you into thinking its playable and then out of no where frame rate tanks...
Reply Quote
Posts: 3
Do we have an update as to when this will be addressed. it's only a mac specific bug as this isn't present on my windows partition. I've attempted to repair the game files and reinstall the game. The issue is interesting, the Frame rate drop occurs within 10 seconds of starting a game SP MP CG.
Once it drops.....it remains consistently low regardless if you quit the match and even go to the WOL main menu......Only way to get it to stop is to restart the game....

I'm kinda bummed this is really the only game I play and it's unplayable on my mac right now.
Reply Quote
Support Forum Agent
Posts: 14,784
Well, the thing is, I'm confused on what your meaning. 1.5.3 came out months ago, and the only thing that was updated recent was a tools update to include the repair tool.

I haven't seen a mass report of this, so I don't think it is all Macs. I tried it on the one here, and I haven't been able to reproduce this.

Can you post full system specs and specific about what FPS you're seeing before and after? Full specs help us see a better picture.

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)

Also, have you tried an SMC reset to see if it helps?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]