StarCraft® II

SC2 won't start after updated OS

Posts: 49
Yesterday, I upgraded my Mac to OS X 10.6.8, and then ran SC2. It did the patching business, and was able to run normally after it was patched. I quit SC2 after awhile and later I went to open it back up again, and I got a screen (like the patch update one) that said

"An internal error occured, please restart."

So I waited a bit, and it worked again. After that, I upgraded my OS to OS X 10.8.2, and got the same error again when trying to open SC2. When I click on "Get Info", it says that the version is 1.0.0.1111

Anything would be helpful, thanks =)

Edit: I've now figured out that if SC is in the applications folder under "Starcraft II", then it does load, but not if you drag it out onto the desktop, like what I had before.
Edited by Corazon on 12/13/2012 1:00 PM PST
Reply Quote
Support Forum Agent
Posts: 14,784
The icon on the desktop before was a shortcut, also known as an Alias. Instead of dragging it, create one and see if that works.

http://support.apple.com/kb/PH10609
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]