StarCraft® II

Unable to download Authentication module

Posts: 11
I have just re downloaded starcraft onto my computer as i had to reformat, now when i try to log in i get an error message, unable to download authentication module.

I have tried turning off my firewall and anti virus but still nothing, i have looked at other threads but none help.
I am running windows 7.

PS: Before this error message it says, CONNECTING TO BATTLE.NET then mumbles on about my internet connection may be down and try again later.
Reply Quote
Posts: 7
I'm in the same situation. Just reinstalled, but can't log in. I have also tried every other suggestion in older threads without any success.

Going to mash F5 until we see a blue response in here, because I imagine they would want to resolve this issue before HotS releases.
Reply Quote
Posts: 11
Bump, really want to get this fixed asap.
Reply Quote
Support Forum Agent
Posts: 29,571
What firewall and antivirus do you have, Dildor?

Just as a test, I would uninstall your security program, try to log in StarCraft II, and reinstall the security program afterwards.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Reply Quote
Posts: 11
I went to the trouble of completely removing all anti virus software and even disabled my routers and windows firewalls, still no success.

EDIT: Id love to see some Blizzard support...
Edited by Dildor on 12/12/2012 2:22 PM PST
Reply Quote
Support Forum Agent
Posts: 29,571
What's the make and model of your router and modem?
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Reply Quote
Posts: 65
It's a problem that has come up after the recent server maintenance and it appears to be causing a lot of different problems.

- If you don't have the battle.net cache folders (fresh install or you have deleted them for troubleshooting) and you only have access to one server, you get what's happening in this thread.

- If you don't have a fresh install (ie cache folders from pre-maintenance), the game either works fine or arcade is broken (as described here http://us.battle.net/sc2/en/forum/topic/7393109519 )

- If you don't have the battle.net cache folders, but have access to another server, you can download the cache folders/authentication module etc from that other server. That leads to the problems described here http://us.battle.net/sc2/en/forum/topic/7392969391
Reply Quote
Posts: 11
@Velnrak Thompson TG782T

@AshuraE So is there a way i can actually fix this issue? Its a fresh download an install from yesterday.
Reply Quote
Support Forum Agent
Posts: 29,571
Can you make sure the Thomson modem is forwarding port 1119 to your computer's current IP address?

http://portforward.com/english/routers/port_forwarding/Thomson-Alcatel/TG782T/StarCraft_II.htm
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Reply Quote
Posts: 11
Done, same issue.
Reply Quote
Support Forum Agent
Posts: 29,571
Let's try it on another User Account in Windows.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Reply Quote
Posts: 65
12/12/2012 02:52 PMPosted by Dildor
So is there a way i can actually fix this issue? Its a fresh download an install from yesterday.

Since it's not on our end (or at the very least it's extremely unlikely to be on our end), there's nothing we can do except wait and make enough noise so that it gets fixed asap.
Reply Quote
Posts: 11
Still didn't work.
Reply Quote
Posts: 11
@AsuraE Lovely hahaha
Reply Quote
Posts: 7
Let's try it on [url="https://us.battle.net/support/en/article/creating-a-new-administrator-account-pc?utm_source=internal&utm_medium=support_forums&utm_campaign=BlizzardCS"]another User Account in Windows[/url].
________________________________________________
Monday - Friday, 8 am - 5 pm PST


Tried this in both administrator and non-admin accounts.

Neither will create a new Battle.net cache folder.
Reply Quote
Posts: 11
:/ Hope we get a fix quickly
Reply Quote
Posts: 11
The lack of blizzard support is criminal, 15 hours since i started the ticket and still no fix. Pretty disappointing.
Reply Quote
Posts: 7
It appears this is a DNS issue plaguing Diablo 3 as well.

http://us.battle.net/d3/en/forum/topic/7392969288

That workaround works for SC2 as well.

It blows my mind that this wasn't identified and posted sooner.
Reply Quote
Posts: 193
Seems the last maintenance really messed with the blizzard servers across the board, having Arcade US issues and SEA connection issues plus D3 connection issues.
Reply Quote
Posts: 4
The message I get is: "Unable to download authentication module."
... it's been a few days now...
Does anyone know of the next patch will fix this issue? Fingers crossed.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]