StarCraft® II

Battle.net Connection Lost (All Blizz Games)

Posts: 76
So yesterday I had the "failed to download a required file" bug, which I solved by doing a clean instal of my entire computer + SC2 (although I have to admit I didn't do it just for SC) And today I have the "download failed" error which I tried to solve by clearing what I though was my cache by following the advice in this thread: http://us.battle.net/sc2/en/forum/topic/2267600188 and now None of my Blizzard apps can connect to Battle.net and I don't know what to do because as per the advice I cleared my trash and lost the file forever.

I feel very frustrated and would like the most straightforward way to fix this.

Thank you,
Reply Quote
Posts: 76
Battle.net Connection Lost

"Unable to download an authentication module. Please try again later." - Starcraft 2

"There was a problem was an authentication module" - Diablo 3

Battle.net Error #114

"Unable to connect..." - WoW

Man that was some poisonous advice, is there any solution to this short of reinstalling everything? I don't even know what to reinstall since it was a shared folder.
Reply Quote
Posts: 76
I've solved the problem temporarily by copy pasting a very old version of the same folder I had on a backup drive instead of the original but now I can't even see the selection screen in "quick matches"...

This: https://us.battle.net/support/en/article/deleting-the-battlenet-cache-folder-mac

Should come with a blood red warning. I feel really pissed right now.
Reply Quote
Posts: 76
So I got two different responses from Blizz to the tickets I made about this problem. One was about fixing permissions on my shared folder and the other suggesting to delete another folder and tinkering with my firewall. Neither of which worked.

Any suggestions? I would really appreciate some technical help. It seem that battle.net shared folder should be re-downloaded when I launch one of the apps, which it is but it seems to dysfunctional and prevents any of the Blizzard apps from connecting (problem downloading an authentication module, error #114 WoW).

Should I just reinstal one of the apps, like SC2, in hopes of generating a new shared folders? Should I delete both the SC2 folder and the Blizzard shared folder and reinstall SC2? I'm scared if I do that it won't generate a new (functional) Blizzard folder... Any suggestions? I feel desperate and I really don't want to do a clean instal of the entire system again.
Reply Quote
Posts: 76
Just tried deleting the Blizzard folder and re-instaling SC2 but it didn't help. The new folder generated still causes the #114 error.... how hopeless. Nobody should ever touch that folder, ever. At least not without making a backup... man I feel dumb.
Reply Quote
Posts: 76
Finished doing a clean instal of the entire system again and low and behold Error 114... I guess there's nothing more I can do. I asked Blizz and they basically told me to take a hike. Thanks for all the help.
Reply Quote
Support Forum Agent
Posts: 14,784
Have you tried to switch your DNS servers from your ISP's to something else? I've seen this from time to time due to a service provider issue, in which temporarily switching to another DNS server helps,

Try using Google's DNS for now and test. If it works after you switch, then you know it is an issue with the service provider.
Edited by Machkhan on 1/21/2013 8:36 AM PST
Reply Quote
Posts: 76
Thank Machkhan, not sure if this would have worked for Error #114 but it worked afterwards for the problem I had loading my profile + quick matches etc. So thanks and now I'm glad to say I'll stop bothering you. ;p
Reply Quote
Support Forum Agent
Posts: 14,784
It looks like some ISPs in Australia/New Zealand are experiencing these issues. Do you happen to be in these areas? We've check it out, and it seems to be an ISP side issue. If you're in this area and the issues persist, then you might want to contact your ISP for follow-up.
Reply Quote
Posts: 2
I am living in Japan and I am facing the same problem. All blz games were ''unable to download an authentication module. Please try again late''.

It starts with I cannot create games vs AI due to ''unable to download something''. I try to fix this by deleting battle.net folder from /users/Share. But I made a mistake and delete all the files under /users/Share. Then the nightmare comes. All blz games were ''unable to download an authentication module. Please try again late''. I tried all possible ways from your FAQ part (all of them!!) and reinstalled both diablo III and sc 2 for a couple of times. None of them works.

What I can do?

By the way, I am using Mac OSX 10.8.2 on iMac (2012late).
Reply Quote
Support Forum Agent
Posts: 14,784
Did you try what i mentioned before and use Google's DNS servers to see if you can connect?
Reply Quote
Posts: 5
01/22/2013 01:27 PMPosted by Machkhan
Did you try what i mentioned before and use [url="https://developers.google.com/speed/public-dns/"]Google's DNS servers[/url] to see if you can connect?


This worked before. Now is happenning again, even change DNS doesnt work.
Reply Quote
Posts: 76
01/21/2013 08:37 AMPosted by Machkhan
It looks like some ISPs in Australia/New Zealand are experiencing these issues. Do you happen to be in these areas? We've check it out, and it seems to be an ISP side issue. If you're in this area and the issues persist, then you might want to contact your ISP for follow-up.


I'm connecting from France actually. Hope that helps in some way. I'm sure you're right about it being an ISP problem but it's strange it wasn't a problem before. Anyways, unlike Lust your DNS solution is still working for me and I hope it continues to.

Cheers,
Reply Quote
Posts: 1
I am having trouble with this in France as well. The DNS solution seems to have done it for now.
Reply Quote
Posts: 5
it seems down load problem continues through out the battle net related games. I am so frustrated when sc2 partially works and now I can not log in to battle net at all. Computer expert has been looking in to it and followed the instruction you tech support gave us but next day problem continues again. I think this is a serious problem for players and hope to be fixed as soon as possible.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]